No field or variable named “webForm”

Tried generating a simple web form (PanoX b31) using these steps:

  1. Took an existing, shared database
  2. Checked the “Web Publishing” checkbox in the “Database Options” window
  3. Created a new form using “Construct” (fields and variables)
  4. Selected “Form > Web Form Converter”
  5. Noted it was generated with 0 errors
  6. Went to the PanoX web status page
  7. Clicked on the database name
  8. Clicked on the form name

… and was presented with the following in Safari:

Panorama X Server Error: labelize( function error: no field or variable named “webForm”.

I’m guessing I missed a crucial step somewhere … :slight_smile:

(Searched the database, and the string webForm was not found anywhere.)

TIA for any suggestions.

The Web Form Converter is not currently documented or supported. However, it might work if you upload the form to the server after doing the conversion. There’s a button to do that in the Web Form Converter window, and also a menu item in the Form window.

Hi Jim,

Thanks for the response.

Yeah, I have tried both … with the same result. :frowning:

Note, FWIW, that if “Show HTML” is selected in the Web Form Converter dialog, that HTML code can be saved to file and it displays properly in Safari. :slight_smile:

In that case, I’m going to fall back to “this is not currently documented or supported”.

Ok, I think I see where the problem might be. You must have instrumentation enabled for the GETWEBTEMPLATE procedure in _EnterpriseWebPublishLib (on your server). If you turn that off, I think you won’t encounter that problem. It looks like there’s a bug in the instrumentation code, but if instrumentation isn’t turned on, it should work.

yeah, I had all instrumentation for _EnterpriseWebPublishLib enabled.
I disabled all of the procedures.

The page now results with:
Panorama X Server Error: Field or variable select does not exist.