Mojave Web Browser Object

After an upgrade to Mojave I find that my Web Browser Objects that reference simple HTML stored in a field no longer work. If I am referencing a URL, the WBO it displays as expected. The objects that don’t work have formula reference to the «fieldname» with the HTML. The WBOs are set to formula in the Web Browser Options (and I have also tried literal to no avail). I also tried inserting HTML into the Procedure tab without luck. I have checked this in 3 databases that formerly had no issues.

Opening the same database on a High Sierra on another Mac, renders the HTML as expected.

This is the same problem that causes charts to not display. I haven’t been able to figure it out yet.

Is there a work around for this?

By the way, the Web Browser Object seems to be completely broken in Mojave.

I believe it is broken when you directly feed it HTML that you’ve generated with a formula. It works ok when you give it an external URL, for example the Panorama Help does this and still works. As yet there is no workaround or fix, though perhaps one potential workaround could be to save the HTML to a temporary file and pass the URL to that file into the Web Browser object.

Thank you Jim,

Your suggestion worked wonderfully

FYI, I have figured out the problem, so a fixed version will be released in the near future.