.ModifyRecord broken in 0.9.001 (2484)? (Resolved)

I have a .ModifyRecord procedure with the code

message “Modified”

as a test, nothing happens. It works with .NewRecord. Can anyone else verify if .ModifyRecord is working?

In my test both hidden trigger procedures worked (somehow), when their names were capitalized correctly.

I found no problem with the .ModifyRecord procedure, but my .NewRecord procedure seems to be triggered by the return key or by the Add Record button in the toolbar, but then actually prevents adding the new record.

I had to add a line of code into the .NewRecord procedure to successfully add a record:

message "new record added"

I tried to find information about hidden trigger procedures in the Pan X Help, but could not find anything. They are not documented yet.

I just copied your .ModifyRecord text just to make sure I was not missing something obvious, still does not work for me. The .NewRecord procedure was designed to give the programmer full control so it makes sense that you would need to add the “addrecord” code. The .NewRecord procedure works fine for me.

Ok, it was something obvious, I had my test field set for a variable, not a database field. Ugh, sometimes I wonder where my brain is. Thank you for taking the time.

I am just testing some more of the hidden trigger procedures. .CloseWindow and .CloseDatabase don’t seem to work here.

This topic was discussed some time back with the various implemented automatic procedures itemized (Automatic procedures). I am not aware of any other auto-procedures added since that time.