Math Menu on Pan 6 - Fill command

In Pan 6 if you have a selection form a database and you wanted to fill a certain field of selected records you simply hit “Apple =” and a window came up and you put the data you wanted to propagated into all records selected for the chosen field.

How do you do that in Pan X? This transition is frustrating at times.



“Apple =” was the keyboard equivalent for Formula Fill… The Fill command didn’t have a keyboard equivalent.

In Panorama X, Formula Fill is Field>Morph>Fill with Formula… Fill is Field>Morph>Fill with Value…

Right, Formula Fill.

Thanks Dave.

Perhaps I can make a Hot Key Equivalent with Keyboard Maestro.

Thanks again.

Keyboard Maestro is a great program, I use it myself. But for keyboard equivalents for Panorama menu items, it’s not needed. Since Panorama menu items use standard Apple code, you can add shortcuts with the System Preferences window!

You never fail to amaze me Jim.



If I had a quarter for every time I hit “apple-’=’” in Pan X I could pay off my house!


I must confess that I am doing something wrong. In Pan X I replicated what Jim proposed and nothing happens. But it seemed that with what I did things were missing.

Chris, did you get this working in Pan X? Or are you joking?



It works for me. Here is a .gif of the process.

Formula Fill

Not for me Dave. Thanks.

If I try to do the Morph even “Missionary Style” from the Menu if I choose Start with field “current field” I get a small red triangle stating that:
“field value( function: data field “Current Field” does not exist.”

What was so simple in Pan 6 eludes me in Pan X.

I have tried this on two computer with different OS and with another database.

Can I be the only person with this problem?

Thanks for your help.

Do I have to somehow define what Current Field is?


If all you want to do is a Formula Fill, you want to use Start with Formula, rather than Start with Field.

If you want a dialog, similar to the one you got with command-= in Panorama 6, you use Field>Morph>Fill with Formula…

That brings up a dialog like this.

It has been working just fine for me. Maybe you didn’t enter it correctly. It needs to be entered exactly Fill with Formula… A screen shot of your setup in Keyboard Shortcuts might be helpful.

Jim is using the macOS System Preferences to create a keyboard shortcut for Here is this procedure, step by step:

  1. You open System Preferences > Keyboard > Shortcuts. In the sidebar you choose “App Shortcuts”.
  2. Click the plus sign to add a new app shortcut. Select “” from the popup menu, then type in exactly the Name of the menu item. In the third field you press the wanted key combination.
  3. Press OK. Now your menu item in Panorama X will show the entered key combo.

A common error is to misspell the menu item, e.g. by using 3 periods instead of the ellipse character “…”. If you miss the exact orthography then the shortcut won’t work.

This is a known bug that has already been fixed for the upcoming b26 update. For now, you have to explicitly choose a field, or choose the Start with Formula option, or use the separate Fill with Formula dialog as others have mentioned (I think that last option is the one you really want).

Thanks Jim, James and Dave.

I will give it another try. I will follow your instructions carefully.

KJM was correct, I was using 3 periods instead of the ellipse character.

I will take another crack at it but using the elliopse character did not solve my problem.



I had also used 3 periods, and that worked. I just now tried the ellipsis, and that works as well. Another possible error would be capitalization. “Fill” and “Formula” are capitalized. “with” is not.

Me too. I pondered the eclipse but didn’t recall the keystrokes.

I did! You have to do it just as pictured- I tried it long ago using the morph menu, but when I changed it to “Fill with Formula…” it worked on the first try.


PS I used three periods, btw.

I have serious problems.

Suddenly the Fill with Formula… worked when I changed the Hot Key Sequence.

Then it stopped working. That scheme works on an Excel worksheet.

Here is something incredibly strange.

I wondered if PanoramaX (10.1) might hae something to do with it. So I highlighted a Panorama X database and had it open with other. I chose PanX 10.1.

I searched for Pan X 10.1 and could not find it. I disconnected all external hard drives, shut down, rebooted. I can open with 10.1 but cannot see it. I even moved Pan 10.2 from my hard drive. Rebooted. Pan X is still there but I cannot find it with Spotlight. But if I click on a pan X datbase it opens with Pan X 10.1!

I thank you guys for your efforts. I am stupified. I am going to do some Virus checking. Also having great difficulty starting the Mac in Safe Mode.

I am on Mojave (so I can still run Pan 6), have a late 2013 Mac Pro with 1 Tera of disk space and 64 Gigs of memory. During this troubshooting all USB connection were directly to the computer. External drives disconnected.

On my second compuer running the latest OS I have similar problems wih the Hot Key. Both versions of PanX, 10.1 and 10.2 are installed but they can both be seen if I do a Spotlight search.

I think I will reinstall from Provue the lastest 10.2.

Weird stuff.

Thanks again for the help.


When an application is opened via clicking on a file, the application will then appear in the Dock (typically with the dot showing the application is open.) So… open your file via clicking on it. Look for Panorama in the dock showing the dot, then Right click (or Control click) and use the Options choice that displays to then choose Show in Finder. You’ll then be shown the application and know its location.

Thank you Robert. That got me to sees the Panorama X 10.1 hidden in a folder I think called .Sparkles. Once again you save my bacon.

I have reloaded Pan X 10.2 and the problem persists. HOWEVER.

The Hot Key works on the datasheet but not on a form! Is that normal? I made a Hot Key for “Memory Usage…” and it works when a form is front and center.

A Hot Key for “Hide Panorama X”, however, does not work when a form is active but does work when the datasheet is active.

Any ideas or can anyone replicate my observations?