Mac Menu Items - not working unless clicked with mouse

I have a bit of a weird issue.

Panorama X doesn’t have many keyboard shortcuts defined. I’ll add some with Keyboard Maestro or default system stuff once I get to know it. But for now, I do ⌘-shift-/ to search help, and type the name of the command. This highlights it in the menu, and I hit return.

For all other Mac apps, that selects the menu item and runs the command. Somehow, with Panorama-X it doesn’t seem to. I see it clicking the menu, but nothing actually happens.

There’s also a great app called Paletro which does the same thing but quicker. Again, this sees all the menu items but Panorama X just doesn’t seem to do anything.

As an example, I tried this on “Morph → Recalculate Field”. The only way I could get it do actually do anything was to manually click on the menu and select it.

First time I’ve ever seen an app not work with this; seems weird! Having to select these in the menu is time-consuming; and setting up keyboard shortcuts for everything is tricky until knowing what I’ll use.

Hopefully you can reproduce.


I just now tried this on three different computers all running different version of macOS from 10.12 to 11.4, and it worked perfectly on all of them. So I’m not sure why you are getting different results on your computer.

I believe he is wanting to access the Panorama Help topics.
When I try it on Catalina 10.15.7, entering text only brings up items in Panorama menus rather than allowing me to access Panorama Help.
And if I do attempt to use it to select a menu item, the menu item is not selected (at least typically.) I’ve just now tried again and 90% of the time it does not work if I use the Return key, just a beep.

No, he is specifically mentioning this in the context of keyboard shortcuts.

Yes, this is a little known feature Apple has built in to the Help menu. If the Help menu is implemented correctly, apps get this behavior “for free”. Very few users know about it (I was unaware of it for many years) but it is a cool way to run apps completely from the keyboard, well not the entire app but the menu commands.

Here is a video showing how this works.


Thanks so much for looking at this. Yes; that’s exactly right - am using it as a way of quickly triggering menu items.

I hadn’t tried the Morph → “Fill with Value” dialogue. This does seem to work (although strangely this still does not work with Paletro).

However; Morph → “Recalculate Fields” doesn’t seem to always work when called like this (though it does if I manually click through the menu).

I think I’ve figured why this is. I think “recalculate fields” won’t work if the field formula is being edited. If you do this via the menu, it works. If you do it with the search trick, it won’t. Here’s what I see:

2021-07-20 11.23.50