Line numbers missing from procedure windows

For some time now, I frequently find line numbers missing from procedure windows. If I click the row, the numbers appear.

Is this consistent in this procedure? Or it just randomly happens in various procedures?

I notice that there is no scroll bar displayed, though there should be. Is there really no scroll bar, or did it not record in the screen shot for some reason?

Has it only been happening in b26, or did it happen before that (if you remember)?

What does “the” row mean? Any row that doesn’t show a number? When you click, does just that line number appear, or all the missing numbers appear?

I am literally editing procedures 5-10 hours per day, I’ve never seen this. Has anyone else?

This reminds me of a tweet I saw just a couple of days ago.

This happens consistently on longer procedures, where one must scroll down to see the whole thing. I definitely experienced it with b25, but I am not sure if it appeared before that.
All of the line numbers appear if I click on any line where the numbers are missing, and the missing numbers partially appear if I click a line where the line number is visible.
The scroll bar appears when I start to scroll (using an Apple Magic Mouse) and then disappears a few seconds after I stop.
Sometimes the missing numbers are a nuisance, but I just cope with it and keep going. Here’s another example.
This would hardly be the first time that I have seen anomalous behavior that you have not seen. If I am the only one (how could that
even be???) then you can appropriately put this on the end of your list. Or maybe it goes there in any case.

In your System Preferences / General, Do you have the Show scroll bars option set to Always or Automatically based on mouse or trackpad?

I can’t speak for Tom, but mine is set for “Automatically based on mouse or trackpad”, and because I am using an Apple Magic Mouse, that means the scroll bar appears when I scroll, and disappears shortly thereafter. I could set it to always, if I wanted the scroll bar to always be visible, but I don’t.

I doubt if Tom considers that to be a problem. He was simply answering Jim’s question as to why there was no scroll bar in his screen shot.

David is correct. Scrolling not a ptoblem; responding to Jim’s question.

So Dave, have you ever seen the problem Tom is describing? I’m guessing not, or you would have mentioned it.

I normally have the scroll bars always turned on (more on this in a moment). Just now I tried switching to the Automatically based on mouse or trackpad setting to see if I could duplicate the problem. I was hoping I would be able to duplicate it, but I couldn’t. It worked perfectly with a bunch of very long procedures. By the way, I also have and am using an Apple Magic Mouse.

I should probably leave the scroll bars set to Automatically based on mouse or trackpad for a while for testing purposes, but I just cannot stand not having the scroll bars visible. I’m afraid if I was in charge of Apple software there would be no such option, the scroll bars were always visible. To me this is just such an important indicator that there is more content beyond the edge of the visible area, and how much content there is. If there’s no scroll bar, my brain thinks there is no more content.

Since the problem only happens on longer procedures, there are many Panorama users that don’t write procedures that long. But yeah, I wouldn’t think you would be the only one.

Apparently you prefer that the scroll bars disappear when you are not actually scrolling. If that is not a strong preference, I would suggest that you might try setting the scroll bars to always on and see if that fixes the problem. At least that might provide a clue as to whether this has anything to do with the problem or not. Though I think the automatic scroll bar option is the default, so probably most users are using the same option you are.

Not that I’ve noticed. The longest procedure I could find was just over 200 lines, and there weren’t any numbers missing there.

I don’t remember noticing this before, and in any case I’m not sure I would necessarily have noticed if I hadn’t read the original post yesterday, but today I found line numbers partially disappearing in a 226-line procedure. Scroll bars are enabled — like Jim, I can’t imagine why anyone would disable them.

Having noticed this and taken this screenshot, I moved the window and the full set of line numbers reappeared, but partially disappeared again shortly afterwards.

I should add: I’m using .b26 running under MacOS 12.4 on an M1 Max. Since moving to this new machine a few days ago I have also tried enabling toolbar icons and seen the same problem that others have.

I’ve been seeing this on b25 and b26 too, but didn’t notice it on previous betas. Perhaps it is evident on longer procedures because when a long procedure opens in a large window all, or almost all, of the numbers are visible, but as you scroll down blocks of numbers start disappearing, and they all, or almost all, appear again when the end of the page is reached.

(b26, 12.4, M1 pro, scroll setting “always”)

It sounds like macOS 12.4 is the common denominator, or perhaps macOS 12.3 or later.

I’m running macOS 12.4 and see missing line numbers in a procedure with 471 lines with each of the 3 “Show scroll bars” settings in the System Preferences → General panel.

The number and location of the missing line numbers are different for each of the 3 “Show scroll bars” settings but also change when you close and reopen that procedure.

I have not noticed this in earlier macOS versions but also did not notice this in 12.4 until I saw this bug report and tried to duplicate this problem.

An example:

  1. Automatically based on mouse or trackpad: line number 140 to 285 are missing
  2. When scrolling: line numbers 95 to 220 are missing
  3. Always: line numbers 122 to 261 are missing (and after closing and reopening this procedure again: line numbers 127 to 285 are missing)

I went to macOS 12.4 directly from 12.2.1 as 12.3 was not available here in Australia when I tried to update to it. I’m pretty certain that the missing line numbers have been happening for longer than the couple of weeks that 12.4 has been available.

I also find that that line numbers are hidden on scrolled pages of long procedures. I’m using a new M1 MacBook Air (no mouse), macOS 12.4, and Pan b.25 – all pretty much “vanilla” out of the box. Scroll bars are always displayed. Any multi-page procedure displays with line numbers on the first page. As I scroll down (via the trackpad), one or two additional numbers scroll up and then a large block are missing, regardless of how slowly I scroll. When I get to the bottom, all of the line numbers for that page (only) suddenly appear. In between those two locations the pattern is variable. I’m looking at one procedure where no line numbers show up (just over a middle page in length) and a longer procedure where they show up in widely spaced groups of 1-4 numbers (usually 2). This seems unrelated to the text content. If I click anywhere in the text area, all of the numbers for that page appear – but scrolling up or down from that will again fail to display numbers. If I reach the top of the file, the first page of numbers again suddenly fills in.

It may be a key observation that those number groups I mentioned are only partially visible, One or two numbers are fully present; an additional number may be half displayed. Either the first numbers of several groups may show only a bottom half (or less) or the last numbers may show only a top half. It appears as if white bars or erasures have been overlaid on the line numbers columns, or the numbers have moved underneath a background rectangle. The overlay (or whatever) then disappears if I click in the text area, or if scrolling reaches the top or bottom of the file.

I think there’s some sort of scrolling bug in macOS 12.4. The code in Panorama that displays these numbers has not changed since 2012 or maybe earlier. It’s actually older than Panorama X since I got it from a friend of mine, it was originally written for another project. I have never touched it, but I can if I need to. I took a look at it today and there’s no obvious reason for this new problem.

For now, I’m going to wait a bit and see if Apple fixes this in the next couple of dot releases, or in Ventura. If Ventura has the same problem then I’ll have to do some digging.