Issue Synchronizing Across Multiple Computers


Our company has four computers using Pan X, on M1 Mac Minis. We use shared databases, and the server is hosted on my computer.

Recently, I was out off the office for a couple of days. While away, my boss used his computer to create several invoices. When I got back, I opened my copy of invoices on my computer, and the invoices he created were absent.

I tried to sync the invoices database, but that did not fix the issue.

Next, I downloaded a copy of the invoice database, from the server, to my computer. The result was the previously missing invoices were now on my copy of the invoices database.

Our company has been experiencing syncing issues for some time now. I have hesitated to post the issue, because I do not have a lot of useful information on what might be triggering the problem. If you have any suggestions on what to investigate, your help would be appreciated.

Thank you!


There were reports of this sort a year or so ago. Some fixes were made, and there have been no further reports of this, until now.

Do you mean you actually downloaded the entire database file, or did you use the Download Data command?

I downloaded the entire database file. No, I did not use the Download Data command.

This morning, while using our purchase orders Pan X database, I noticed that my boss had created a couple of POs late last week, but it wasn’t showing up in my copy of purchase orders, on my computer. Today, instead of downloading the entire database file, I used the command Download Data. This downloaded the missing POs that my boss had created earlier.

You might want to do a “New Sharing Generation” of that database. It sounds like there is a problem with the database metadata, and doing a new sharing generation would reset all the metadata.

Thank you Jim. I presume a New Sharing Generation is accomplished using the following screen.

Is that correct?

What event might trigger a need to reset all the metadata?

Pretty much. I should have specified that. you need to do a Critical new generation, and make sure the Field Arrangement and Data Types option is checked (this will automatically check all of the other boxes).

There shouldn’t be any event that causes this. But it sure sounds like something has happened to your database that is continuing to cause problems, so trying a new sharing generation is the only possible fix I can think of.