Is one record corrupted?

Is one record corrupted? I have a large database of 749 records. Just 4 fields, mainly the large Notes field. The first record no longer contains its former data in the Notes field and has instead plugged in a copy of the Notes field data from one of the other records which also exists in its proper place. Using Time Machine I looked at a one year old backup. It also lacked the correct data in this record, but a different record’s Notes field appeared there. This happened once before and I just worked around it. But this is really worrisome. What else can be corrupted?

Any suggestions? Is there any one-to-one help here?

Mojave 10.14.6, Panorama X Pro 10.1.2

This doesn’t sound like corruption, it sounds like you have accidentally pasted data into this field and didn’t notice it at the time it happened.

That’s what I thought. It’s very easily done, especially to the first record.

I too have recently experienced some similar oddity. I have a procedure that sends an email. It typically loops down, record by record, customizing the emails as it goes. Yesterday, it sent one email then filled in 2 fields with some text that I am not sure where it came from. No part of the procedure was supposed to be modifying any of the db. I only viewed a partial amount of the text to know something odd was happening and it was obviously a segment of text from somewhere in memory.

As this procedure had run just fine many times before, I repeated attempts to run the procedure and even tried Quitting Panorama and then re-running the procedure. The odd pasteing of text in that first record persisted. It was only after a restart that Panorama again ran the procedure properly. A real oddity but just wanted you to know that it may not have been you.

I have also experienced overwrites to my databases at other times recently but this time I was able to watch it happen as I repeated running the procedure which was supposed to step through each record but instead sent the first email, then did the overwrite and stopped without going to the 2nd email. It was very clear to me that something was wrong.

I agree that might sound like a simple explanation. But it wouldn’t be THAT easy to make the mistake. I’d have to copy the errant data, select the entire Notes field in the destination field that could be a screen or two long, and paste in. Also, when I looked at the database from a year ago it had a totally different record “pasted” into that record. Doesn’t seem like an easy mistake.

Well, thank you for that. Misery loves company.

My database is very simple, unlike yours. I wish I had more confidence in the situation. It’s pretty scary.

It is. While the data sheet has input focus but a field is not being edited, command-C copies the contents of the current field to the clipboard or command-V copies the clipboard to the current field. Very easy and very useful most of the time, but potentially dangerous too.

Does your database have any procedures? An error in a procedure is another possible explanation.

I have this happen often. When I change one record (not copied and added to clipboard) and then sort the database, the first record will be filled with info of the changed record. It does not happen every time, so it cannot be a problem with the sort procedure.

Another strange occurrence. I have a daily order database I append to a history database and then I add the daily file info to a sales tracking database. After the daily file is added to the sales tracking database, the daily file is cleared, one blank record added and saved. However the next day when I opened the database, often the previous days data appears. Cannot figure out why that happens.

It would not write over the existing text unless I had highlighted that text first. Just copying and pasting would not replace the previous text.

Certainly sounds like a bug to me. I hope this will be investigated. Databases should be 100% reliable. I do realize that intermittent problems are the hardest to fix.