Invalid server reply dictionary

Image 6-30-22 at 2.56 PM

Without any context, I can’t elaborate on this alert. It could simply mean the server isn’t running. Or there is some sort of network problem.

My user is unable to add my server as a remote server. He keeps getting the Invalid server reply dictionary alert.

My server is running. Apache is running. The domain name is correct (192.xxx.xx.x). The port is 8080. Local connections only is unchecked. On my router I have port forwarding set up 80>8080 for the server computer. I am not experiencing any other network problems. My local network clients can all see the server both on bonjour and as a remote server.

What am I missing?

One other possible clue is this: my user’s computer belongs to a university. Could their IT folks have set it up in some way that is interfering with its ability to make this kind of connection? I have something to check that should be relevant to that question. (Dave T, do you have experience with this? Since we’re both retired, we don’t have to confront this behavior any more, thank goodness, but I’m aware that it exists.)

More info. It’s not the problem mentioned in the last ¶. I put PanX on my wife’s computer, and took it out of range of our local network. When I tried to add my server as a remote server I got the same invalid server reply dictionary alert. So it’s not something the University of Idaho is doing.
BTW, the IP address for the server is fixed, so it’s not that.

192.xxx.xxx.xxx is not a domain name. Then too, that IP address is not a routable address.

When it is said that your router has port forwarding set up to the IP address of the server, that is good. But the IP address that the remote client needs is the public IP address that the router has.

From the client computer, try https://canyouseeme.org/
Using that service, type the router’s public IP address using port 80. The service will tell you if your configuration is correct.

That is a local IP address on your network. It won’t work for any computer outside of your network.

What you need is the public IP address of your router. But it sounds like this is a router in your house, in that case it won’t have a public IP address. You either need to have a static IP address (which you would have to arrange through your ISP for an additional charge – if they even offer that service) or you would have to set up a dynamic IP address system. I’ve never set up a dynamic IP system myself, but I know some Panorama users have had success with this. Note – it’s also possible that your ISP may block incoming traffic on port 80, many ISPs do not allow web servers.

This option doesn’t mean what you are thinking it does. If it is checked, the server will not allow connections with ANY other computer, even on the local network.

Unfortunately, setting up a server on the public internet is a non-trivial task. This has nothing to do with Panorama, it’s true for any kind of server.

The issue of the router having a public IP address varies from ISP to ISP. Some do, some do not. If the WAN side of the router is a 192. or a 172. or a 10. , then the user does not have a public IP address. If the user has some other IP address, then they do have a public IP address.

Indeed. I’ve used No-IP for years, as have several others I know of. They have a small app that goes on your computer to communicate with their server to keep it up to date on any changes with your IP address. For a single address you can get a free account. That said, technically I have a dynamic IP address, but it’s been static for a very long time.

Solved! My router does have a public IP address, and using that with port 80 is completely successful. My reading suggests that the router’s public address won’t change, but if it does I’ll remember about No-IP.
Many thanks, Jim, James, and Robert. Things are working as they should and I’ve learned a bunch along the way.