Internal Dialog Logic Search Errors

A database with 127,000 records won’t allow me to search. The Search dialog appears momentarily, closes and ends up with one of the following dialogs, even after a Quit and relaunch. The querySpec is more frequent.

Screenshot 2023-04-05 at 10.25.26 AM

Screenshot 2023-04-05 at 10.26.23 AM

The following like MicroSoft support saying, “Reboot your computer” … " so I feel I should already apologize.

  1. Export those records as txt.
  2. Import into a new PanX database
  3. Try the search from a menu, not a procedure

I’m guessing you know all that.

I have searched a database with many more records and it worked fine. So perhaps something besides the Search is in play - some corrupted support file?

I assume you are saying that search works for all other databases, just not for this particular one? As Paul stated, there should be no problem searching 127,000 records.

If you want to send me the database, I can certainly try to duplicate the problem, in which case it could hopefully be fixed.

An old way to ferret out corrupted data from the DataSheet (and sometimes fix it) is to copy all fields onto themselves, column by column. Might be worth a try… (?)

Today in preparing the file to send I opened it in Diagnostic Mode. The searching worked. I quit and re-opened it normally and the search has continued to work. I’d been in and out of it throughout the day and so far it has functioned properly.

I’ll certainly keep an eye one it and if the problem shows up again, I’ll do what I can to document the circumstances and send it.

Otherwise, it’s apparently a never mind. :roll_eyes:

1 Like