Interesting quirk

Select a database cell (turns red), then adjust the field length by dragging the field margin to the left. The field length adjusts but the red stays where it was. Selecting the cell with a return clears the discrepancy. Red stays with the cell when adjusting the field length to the right.

Are you talking about in the data sheet?

Interestingly, I was able to duplicate a problem like this in the data sheet in my development copy of Panorama running under the Xcode debugger. The problem occurred whether I dragged on the left or the right. But it worked fine when I tried it on the b25 version, which I presume is what you are using. So I’m not sure if I’m seeing the same problem you are seeing or something completely different. My development version has been updated to run on a newer version of the macOS SDK, and I’ve been chasing down a number of cosmetic problems caused by this newer SDK (the newer SDK is required for M1 native apps). So I’m not sure if I’m seeing the same problem you are seeing, or if I even understand what you are describing at all. Maybe you are talking about a cell in a form?

Oh fun, I just discovered that dragging a field to a new position doesn’t work with the new SDK. :sleepy: I’ll add that too my list.

Clicked on “Beethoven” and dragged left. The red highlight stayed behind!

Yep, data sheet

Oh, and using Panorama 10.2.0.b25 (3901) running MacOS Monterey 12.1.


I think. you mean you clicked on the gap between “Composer” and whatever the next field is. I can get a similar result to what you are seeing by doing that and then dragging right – dragging left also is a problem but a different result. But for me it works perfectly when using 3901, it only fails with the internal 3914 release I am using. Oh will, I will fix that version and we’ll hope it fixes it for you also. If not, let me know (after the next version is released, of course).