Integer fields being treated as text

I have the following integer fields

I have the following formula, for which I have confirmed all of the variables are numbers:


I get an error message “Cannot Multiply Text By Number”

I also have the formula in which Member=36 NonMem=12, Coupon=5, Child=0, General=0


Which produces the result 3612005

I’ve tried putting the second formula in the TotalAttend data sheet formula and get the same results.

Haven’t tried using val( as it seems it should not be necessary.

Do I need to go to floating point?

[tried indenting the formulas, but it wouldn’t take]

How did you go about confirming that the fields were all integer fields? If either Member or NonMem were a text field, you would get the results you describe. Those are the only fields that could single handedly be responsible. If other fields, in addition to those, were also text, you would also get those results.

You need to have a blank line prior to the indented text. I added it for you.

If you really want to sort it out, take each addend and test it individually in the Formula Workshop.

And with no changes made, I re-open the db this afternoon and the problem has mysteriously disappeared.

I wonder if perhaps you somehow accidentally created variables with the same names, and the variables contained text. That would account for all of the symptoms, including the fact that it worked when re-opened (since the variables would no longer exist).