Install problem - Panorama 6 - lib failed

I have a client who is having problems installing Pan 6 on a Windows 7 machine:

Panorama 6.0
libraryfailed! C:\Program Files

I have had him attempt to re-install Pan6, but still gets the error message.
He claims that when the user opens Panorama, the error message appears. He says he “can start it up as admin without issue, when the user attempts to run it they get the error.”

It sounds like a permissions issue within the Libraries folder in the Panorama folder. Part of Panorama’s startup routine is to open _PanoramaLib and run a procedure in it. The error is saying it couldn’t open that file.

Thanks, Dave.

I discarded Panorama 6 after installing Pan X and encountered this problem. I can’t now reinstall Pan 6, so I don’t have _PanoramaLib on my system. How do I fix this problem?

In your case, it sounds like Gatekeeper randomization. Your installer has its own copy of _PanoramaLib, which it can’t find. Read the instructions at

to see how to get past this.

Thank you very much. I used the alternate solution to get by the problem.
I appreciate your help. Eric

Having problems installing Panorama 6 on a 10.13.4 macOS High Sierra. I’ve tried the standard installer and got the lib problem. I tried installing it from the Pano X installer method and the installer worked but then I had the code -7 error. I am unable to alter the Sharing & Permissions area of the drive by adding the user as the system then reports ‘The operation can’t be completed because you don’t have the necessary permission.’ I’ve also tried logging in as root and doing the above to no avail.

Any other ideas to get past the code -7 while using 10.13.4?

You need to disable SIP (System Integrity Protection). A quick google search will turn up instructions for doing this.

Worked. Thank you.

After the registration is complete, can we reenable SIP?

I think so, but I am not 100% sure. If you try it, please let us know.

For system security reasons, you should reenable SIP immediately.

That link is now a 404. Another link to the answer?

That link is now a 404. Another link to the answer?