Getting procedure compile errors for no reason

Hello Friends,
All the sudden I am getting compile errors on my procedures. I have copied the text into another procedure and I still get the same errors. For the life of me I can not figure out why I am getting compile errors and unknown statements. Everything looks good to me.

Make sure you do not have smart quotes. Maybe try another quotation character.

Thanks Bruce. I am not sure what smart quotes are. I really did nothing different, the procedure worked just fine before. I am going to restart my iMac just in case.

The OpenForm "Registration Fees Listing is missing the closing quotes.

Line 13 is missing a quote at the end of the line, after the form name. As a result Panorama thinks the form name includes all the text up to the middle of line 16. It then thinks that Data is the next statement, and since there is no such thing as a data statement, an error occurred.

Mismatched quotes are always tricky, as are mismatched parentheses or any kind of mismatch error. Panorama has no way to know where you really intended to put a trailing quote, so it just continues merrily along through your code until it runs off the rails. In this case it was pretty easy to see the problem since it occurred in text that was supposed to be a quoted text constant. When you see that it’s an immediate clue that there is a missing quote somewhere above the error.

I feel so stupid. I did not see the missing " at the end.
The thing that threw me off was the error was on line 13 but the warning made it sound like the error was on line 16. Thanks again for this quick help.

This is typical when there is a missing quote – Panorama cannot detect the error until it comes to another quote, which may be many lines later.

Hello CMTA,

Color is a great help in macros. Notice in your early lines that statements are in BLACK color (Openfile, Select, Field, etc.). But starting at line 14, all statements are BLUE.

A sure sign that something is amiss before line 14.