Form corrupted? Can not select an object

I use a set of files daily and one of them is very busy with objects of all types. If I move it to Graphics Design Mode and then attempt to select an object, I immediately get a beachball. Other files have no problem. Other forms in this file do not exhibit a problem. Only this VERY complex form. (76 buttons, 32 pop downs, 82 checkboxes/radio buttons.) My Time Machine backups going back to January all exhibit the same symptom. I’m pretty clear that I’ve made some modification to this form in the last 3 months but alas, I can not make any selection without causing Panorama to hang.


Two possible ways to go at it. Copy Form, Paste Form to see if another copy escapes the issue. And/Or a copy of the database with no data.

I’ve tried both of those ideas with no luck.

Other ideas?

There’s really no way to recover a corrupted Panorama 6 form.

In Panorama X you could try saving the form as a blueprint, then reinstantiating it (the equivalent of exporting everything and re-importing it), but in Panorama 6 there’s really nothing you can do.

Woo Hoo! I don’t know what the upper limit of stuff on a form is but I apparently hit it.

Something told me that my friend patience needed to be sought out. I drew a selection rectangle around some unneeded paragraph objects. The rainbow cursor starting spinning. About 5 minutes later, my standard cursor was back. I hit the Delete key. Again the spinning rainbow started (and the Force Quit Applications window showed Panorama not responding). After about 5 minutes, the objects disappeared and my cursor was back. I continue in that manner and after removing some random objects on that first pass through, my form was normal again. I continued to delete other unnecessary objects to take my form back to some acceptable level and I can breath again. :slight_smile:

Off screen from the normal tiles, I often keep old objects of word wrap or such in case I need them again so I did have plenty of stuff to remove. I am really quite shocked that the limit was hit by my form as those limits are usually quite high, beyond anything that any normal person would ever hit. But something told me that I needed to try this and voila, it worked and I’m happy.

My experience (and now yours) is that this item of information is almost always spurious in Force Quit and in the Activity Monitor (they probably have the same source). Patience is a virtue - cultivate it.

There shouldn’t be any limit on the number of form objects other than available memory, and form objects are small enough that I would think it would be impossible to come anywhere near exhausting available memory. As you add more objects Panorama should get slightly slower, but there is no reason there should be a break point where suddenly it gets a lot slower, or conversely, where it gets a lot faster as objects are deleted. It sounds like maybe you had a particular object that was corrupted somehow and deleting that object cleared up the delay.

the Force Quit Applications window showed Panorama not responding

Normally any application is constantly checking to see if the mouse has been clicked or a key pressed. But if the application has a long task to perform, it will temporarily stop these checks. When it does that for more than a few seconds, Activity Monitor and Force Quit will say that it is not responding, and the cursor changes to a ranbow. That usually just means that it is very busy and doesn’t have time to do the checks. When the task is finished, the application will resume the mouse & keyboard checks and everything gets back to normal. Ideally you write programs to avoid this kind of long task, but it’s not always possible.

Of course if a program has a bug it could actually just be looping continuously and not actually making any progress toward finishing. There’s really no way to tell the difference between an actively progressing task and a hang like this other than waiting a while.

If I know a task is likely to take a long time, I’ll add a progress indicator. However, something like selecting objects is not ever expected to take that much time, so it doesn’t have a progress indicator. (Adding a progress indicator is quite a bit of work and will actually slow down progress a little bit.) In some cases the long delay is in Apple’s code, not mine, so there is no way to indicate progress.

I was aware that there should not have been any limit to the complexity of the form. And it was due to that understanding that I tried several other things first in attempting to figure out the problem. Heck, I even did a re-install of the system twice while thinking that there was some cause beyond Panorama or that Panorama was corrupting the system.

But when I moved back to the Form, just because of a gut thought, I specifically went first for some items that I hadn’t touched in years. My thought was complexity and I wanted to just remove complexity without items that had been added in the last year or so. They were far out of my typical working area, were chosen at random, and poof, once those 3 or 4 paragraph text objects where successfully selected and deleted, everything else was normal. It could not have been that I happened to delete ‘the’ corrupt items on the form.


I opened one of the Time Machines copies that I had found was also causing the ‘hang’.

I randomly chose and clicked on a different single item, a check box. This item is my working area of the form. The spinning beach ball immediately presented and displayed for 3:20. After that time, the item was selected. My cursor returned. I pressed the Delete key. Again the spinning beach ball for ~3:20. At the end of that time, the item disappeared as desired. Every additional selection of an item was immediate and the deletion was immediate.

In my initial ‘fix’ of the form, and in today’s fix, the form was working normal after the first select and removal of an object(s). Different objects randomly chosen. Today I only had to remove one object. Yesterday I had chosen 3 objects but apparently I just needed to bring it back within some unknown limit.

Yesterdays fix was done with no other applications open. Today’s fix was accomplished with Chrome having 32 windows open (with an unknown number of tabs), 7 applications in total open, Mail having 23 open emails displayed, etc. 16 GB of memory. Yesterday’s delay wasn’t timed but was probably similar to todays.

There is a limit on the number of items or complexity of a form. I didn’t think there would be any limit that I could hit without being stupid and purposefully creating a problem.

The attached is a pic of the form with most of the objects and 1/2 of the fields in use.