Forcing data entry into a specific field

I have several text editor objects in a form. Is there a way to specify that any text entered from the keyboard will go into a specific object without clicking in that field first?

If you don’t want to enter any text into the others, you could replace them with text display objects. If your text editor object is the only one, and you start typing after the form opens, it will go into that object.

If the form is opened by a procedure, you could include something like this in that procedure

objectaction "ObjectName", "Open"

where ObjectName is the name of the text editor object.

That certainly did the job… maybe too well. After opening a text editor object using the objectaction command, clicking in one of the other text editors had no effect: text STILL went into the object I had opened. So that solved one problem and created another one. I think I can work AROUND that one, though.



If you double-click the other, or tab into the other, it should work for you.

Are these regular Text Editor objects or do they have pop-up editing turned on? If the latter, you’ll need to double click to switch to editing a different object (as in Panorama 6). If the former, a single click will do it (which I just confirmed).

Regular… no pop-up editing. A single click works to select a new field THIS time… I don’t know why it didn’t earlier. (Gremlins?)

I also found that a tab works only if you have tab set as a termination key. Otherwise a tab just inserts spaces.

I have successfully gotten things to work using the enter key as a terminator and skipping from one field to another. [Address to Zip] But although the Zip object in the form is highlighted (it’s a TEO with popup editing enabled) I still have to click in it (once) to edit it. I tried using Dave’s suggested line
objectaction "ObjectName", "Open"
with and without popup editing enabled and I still have to click in the field to edit it.
I put a little button in the form to message me the name of the active object, and it shows blank (although the target object (Zip) is highlighted) until I click in it. Then the Message shows the name of the target object.
So to sum up, I can get code in a form to take me from one TEO to another (out of data sheet field order), but I can’t find any code to actually open the TEO for editing.