Force Quit with printtopdf if no Default printer is set

In getting a printtopdf procedure put together, I hadn’t set a default printer. Panorama reliably locks up and requires a Force Quit. Neither the OK or Cancel buttons would allow me to otherwise resolve the situation. I could drag the windows around to set up the screenshot.

Screenshot 2023-09-06 at 1.00.55 PM

BTW, the documentation for PrintOneRecord does not make it clear that empty quotes no longer move on without a dialog.

When the options parameter is empty text ("" ) Panorama simply uses whatever print options were used the last time this database was printed.

I’ve encountered this before and have used printtopdf to resolve it. But I don’t use it often enough to always remember and find myself resorting to printonerecord, then troubleshooting its failure.

A documentation correction has been submitted.

I’m confused by your post. When you need to force quit, where. you using printonerecord? or printtopdf?

In any case, the alert that you shared is not part of Panorama’s code, it must be part of Apple’s code. So I’m at a bit of a loss as to how this can be fixed on ProVUE’s end. Maybe something will come to me.

I’m thinking it is most likely that you were using printonerecord, the Print dialog opened, and then the hang occurred after you pressed the Print button. Is that correct? In that case, this would definitely need to be fixed by Apple.

Does this mean that you hadn’t set up a default printer, or that you hadn’t set up any printer at all? In the latter case, I think this means that info(“printers”) would return empty text. If that is the case, I think that I could head this problem off by checking that list before starting the printing process at all. Though that would also prevent you from opening the Print dialog at all, so you couldn’t make a PDF unless there was a printer connected.

My intention had been to modify this so that empty text would work like it did in Panorama 6, so that’s why this wasn’t modified in the documentation. However, I now think that the modern macOS does not include an API for this. So thank you for submitting the documentation change.

Apologies for not stating it clearly. The procedure in the screenshot was intended to demonstrate that I am using printtopdf.

Although I have two printers listed Printers & Scanners, the first time I encountered it, both printers were turned off. I tried it again and again got the situation that required a Force Quit.

I turned one printer on and set it up as the default printer. Then the procedure ran without issues. I turned the printer off and the procedure would run without issues.

It seems flaky, but as you pointed out, the error dialog is not of Panorama.

Oh, duh. I didn’t even look at the background of the image. :melting_face:

However, I still would have needed the clarification, so thanks for that.

I have made a change to Panorama that I hope will cause it to produce an immediate error if there isn’t a default printer. However, I was unable to duplicate your results by turning off all connected printers. The computer still thought there was a default printer set up (at least according to System Preferences, and Panorama didn’t hang). I suppose I could delete all the printers from my computer, but I’m just not feeling that dedicated to the cause today! However, I think it will almost certainly work, so feel feel to try it again once the next version of Panorama X is released. (And if it still doesn’t work, I don’t think there is anything further than can be done on my end, which is another reason I’m not going to the trouble of deleting all of my printers.)

I’m never likely to see it again anyway, but figured anything that requires a Force Quit should be reported.