FontAwesome icon buttons

i can’t seem to figure out what I, doing wrong. According to the instructions I choose an icon and make whatever changes I want then click on MAKE BUTTON. I have an open form ready in graphics mode but no button gets created.

What am I missing here?

Looks like that wizard is broken. I get this warning when I try to make a button even though the form was in graphics mode when I opened the Font Awesome Icon wizard:


If you check the Embed Style box in the wizard and then copy the code you can add it to the Title area of a button object in your form. Make sure the Rich Text option is turned on.

Just to be contrary - it works for me every time. The select icon and style appear in the upper left corner of my form.

Yes, everything appears correct on the wizard form with the icon and style but generates an error when the Make Button is pressed.

No button is ever created. I’m still on OS X 10.13.6 (17G8029).

It works perfectly in macOS Mojave (10.14.6).

It doesn’t matter whether the form was in graphics mode when you opened the Font Awesome icon wizard, it only matters whether a form is open at the time you press the Make Button button. In the movie you posted, I don’t see a form open in graphics mode (of course the movie is cropped pretty tight).

Here is the start of the code in the Font Awesome wizard that find’s the topmost form in graphics mode (if any).

local graphicsModeWindows,targetWindow
arrayfilter info("windows"),graphicsModeWindows,cr(),?(windowinfo(import(),"type")="Draw",import(),"")
arraystrip graphicsModeWindows,cr()
targetWindow = firstline(graphicsModeWindows)
if targetWindow=""
    nsnotify "Cannot create button","TEXT","Please open a form in Graphics Mode."
window targetWindow

Leo, I would guess that you don’t have any form in graphics mode, and you don’t have notifications enabled for Panorama X. Panorama X uses notification quite a bit for warnings like this, I would recommend making sure they are turned on.

As you can see, the form is open in graphics mode and the error notice is shown.

Ok, I tracked down the problem. The form I had open in graphics mode was named Test and I also had a procedure open named Test. The windowinfo(import(),"type") was returning Procedure for both windows. When I closed the Test procedure windowinfo(import(),"type") returned Draw for the Test form in graphics mode and the button was properly created by the wizard.

Oy vey - allowing for multiple windows with the same name will not be an easy fix. I’ll have to come up with an alternate way to specify a window, perhaps by front-to-back position (1, 2, 3, etc.), both in the windowinfo( function and the window statement. Or something similar. This could be useful in other applications as well.

Thanks for tracking this down Gary. Leo, is this the problem you are encountering? a form and procedure open with the same name?

No Jim. In fact there was no procedure open to begin with. All that happens is once the MAKE BUTTON button is pressed the form in the database comes to the front. if it’s not in graphics mode a warning comes up stating the form must be in graphics mode.

FYI I tried it on a couple of different converted databases and the same problem. I then created a new database in PanX, created a new form, and still no button created.

Using Mojave 10.14.6

If there is no form in graphics mode then no window will come to the front.

I can’t imagine why this isn’t working for you. Other than the problem Gary just reported, there has never been a reported problem with this. I use this feature frequently. It doesn’t matter what version of macOS you are using.

I would ask you to send me the database, but since it sounds like the problem isn’t tied to a specific database there doesn’t seem to be any point to it.

All of the artwork appears in the Font Awesome window itself, right? If so, that indicates that Font Awesome is working on your system. The Font Awesome window itself is actually a Panorama database. A number of other Panorama dialogs and sheets also use Font Awesome icons, and even some of the toolbar icons are actually Font Awesome icons.

You can also create Font Awesome buttons manually – they are just Text Display objects. Could you try creating a Text Display object? Once the object is create, make sure the Rich Text option is checked. Then set the formula of the object to:


That should display an icon.

See How Icon Buttons Work on the Font Awesome Icons help page for screen shots showing how these options are set up.

Well it doesn’t work so now what? BTW I copied the code to the button title with Rich Text on and I get the icon but I can’t get rid of the button outline, see attached clock image. 50%20PM

Yes I was able to create a working button using that work around method but I’d much prefer that things worked as they should!

Make sure that the Border option is set to None.

I didn’t really mean that as a workaround, just as a way to verify that Font Awesome is installed correctly. It appears it is, so we can rule that out.

My next suggestion would be to close ALL Panorama windows, quit Panorama, then re-open it, create a new database and new form. Make sure no other windows are open, and the form is in graphics mode. Then open the Font Awesome window and attempt to create a button.

If that still doesn’t work, I’d like to know if you can create objects with the dialogs in the Construct menu. They create form objects the same way as the Font Awesome window does.

Thanks Jim, I did as you instructed and no button was created. In fact first time out I got the warning message you see in the image. After I restarted PanX and attempted Font Awesome all that happens is the window of the new database comes to the front but no button.

I then tried the Construct menu and either I get the eternal beachball or nothing.

With all these problems I’m having could my PanX installation be seriously damaged? Perhaps I should remove PanX using Clean My Mac which will also remove all support files then reinstall? Of course I now can’t remember how to reestablish my account!

The problem with the Construct menu is one that I have reported to Jim, and sent a sample. There are numerous problems with Graphic Mode and converted databases.