Following the Matrix Object tutorial, fail

I followed the tutorial, seems easy enough.

  1. Dragged a matrix onto the form.
  2. Created Frame Object.
  3. Selecting the matrix, and in “Formula”, I entered then applied…
    “a
    b
    c
    d”
  4. Dragged a Text Display object into the Matix Frame (fully inside the frame’s boundary). Text displayed “Text”. Then I clicked “Refresh”. As shown in the tutorial, the matrix displayed “Text” in each cell.
  5. For the text display in the matrix frame, in “Formula”, I replaced the default text with info(“matrixcelldata”) - I was careful to use non-smart quotes. Clicked Apply then Refresh. Instead of getting one of the letters a through d, I got info(“matrixcelldata”) in the frame and the Refresh put that string into each cell of the matrix.

I’ve repeated this countless times and have gotten the same result (yes, I know that is an indication of insanity). What have I missed?

The only way I have been able to duplicate your symptoms is to set the text display object to Literal Text. It should be set to Formula.

Screen Shot 2021-11-09 at 4.13.39 PM

When creating a new Text Display object it normally defaults to Literal Text mode. If you want, you can change the default to Formula mode.

Thanks, that fixed it!