Find/Select Problem

In the last month or so, I have been upgrading my databases to Panorama X. It is lengthy but very interesting.
However, I hit a snag, today. One of my main databases, “Log,” now consistently responds with an error message to Find/Select (in either the title bar or in the menu, when the active window is either the data sheet or a form). “Error Wizard” declares in red, "Changeobject statement can only be used in a form window.’ It notes 1. Database _FindSelectLib, Procedure FINDSELECTDIALOG, 2. _FindSelectLib, Procedure execute, 3. Database _DatabaseDialogLib, Procedure TOOLBARMENUBUTTON. There are arrows which look they should be clicked, but nothing happpens when I do. Then it notes some code which is not possible to copy. The Error Wizard window is at the front of all Panorama Windows – you can’t click on them. It doesn’t close by clicking the red dot in the upper left, by cmd w, cmd periord, escape, cmd escape, or F6 escape. I have to invoke Apple’s cm opt esc to force quite Panorama.
I thought this might not be a problem since I tried find/select in a form window: but same thing
Any thoughts about how I can stop this, or dismiss it, or otherwise find and select, orat least figure out what’s going on?

Normally, the Error wizard gives you the chance to use those arrow icons to jump directly into the procedure causing the error, and the Error wizard window would close as expected. So there is something wrong.

I would first try to see if the problems happens again after a restart of Panorama X.

If it does, I would try to see if it happens again after a restart of the Mac.

If it does, I would try a re-installation of Panorama X.

Perhaps someone could suggest what I might be doing wrong.
As suggest above — suggestion much appreciated — a program restart, and a computer restart were tried, but the problem persists.
So I would like to reinstall PanoramaX. There is where maybe someone can help out.
I understand that the way to do this is to download Panorama X from the Provue site. This would be a trial version, understanding that after running it, it will have a way of entering my lic into it,
So I click on “Download Trial”
A window opens which says “click the [blue cloud with down arrow graphic] icon above to start the download.”
I see the icon in the upper left. Text next to it says”” and “Version 10.1.2 (2854) — November 15th, 2018 (47.4 MB)
I click on the icon.
I see new text in the lower left screen: “"
But there is no download.
None shows up in my downloads folder, none elsewhere that I can find by searching for recent docs, files, apps, or for name “Panorama," No download documented either by my browser.
There is no download.
This I have tried a number of times.
I am able to download files and apps from other sites.
Is there another way to reinstall Panorama?

That is not what I am seeing. The link reads correctly and the download is working here.

We haven’t had any other reports of problems downloading Panorama X.

As far as the link goes, both of you may be right. When I hover over the icon, I see the same preview of the link that Matthew sees, without the http:// portion of the URL. It may be a setting of the browser whether or not the http:// portion is shown in the preview. I tried it in Safari and Chrome.

The download doesn’t start until I actually click the icon. At that point the browser is using the full URL, including http://. But all you should have to do is click the icon and it all should be taken care of for you, the downloaded file should appear in your Downloads folder.

Thank you, thank you!. My computer read a slash and yours read a dot. I tried the dot, and it worked!.