File menu, Rename... command

I am unable to use the “Rename…” option in the File menu. I have made a copy of one of my existing Panorama X files, and now I want to change the name of this copy. But nothing happens - nothing at all - when I click on “Rename…” Can anyone help with this?

I get the same action when trying the Rename command - nothing! Alternatively, if you hold down the option key when clicking in the File menu you will have the Save As… item appear. Choosing this will save the existing file under a new name and/or location and then leave it as the open database. The downside is that you will still have the original database on your hard drive which would not be the case if the Rename command actually worked. It sounds like this would have accomplished your end goal if you had used Save As… to begin with.

1 Like

I just tried this, and you are correct, nothing happens. I have added this to the issue tracker for future resolution.

In the mean time, you could use Save As as Gary mentioned, or you can simply close the file and then rename it in the Finder.

Thanks very much for the help. In fact, I wanted both files, the original, and then the copy to make changes to without altering the original. Would there be some other way to accomplish this?

There are two options from the File menu that will allow for making a copy of the existing database and retaining the original database. I previously mentioned the Save As… method that is available by option clicking or right clicking the File menu. If you use this method you will save a new copy of your existing database under a new name and/or location and this new version will now be the one that is open and active while the original will be closed.

The second method is to use the Duplicate choice from the File menu. This method will simply create and open a duplicate of your original database with the word Copy added to the database name. At this point you will have both versions open in Panorama with the copy the active database. Note that the new copy will not be initially saved to disk.

If you are going to use a procedure to do these things you can use the saveas statement which is the same as the Save As… in the File menu, or, you can use the saveacopyas statement which differs from the Duplicate menu choice. Saveacopyas simply saves a copy of the original database the same way as saveas but does not open it and leaves the original database open and active.

Here are the Help pages for the two statements:

In addition to the methods Gary mentioned, you can of course select the file in the Finder and choose File>Duplicate (or press Command-D).

I tried File>Rename, and since I have used this before, I found that it works fine if you are aware of what you need to do.

So you choose File>Rename.
Click on the Name at the top of the window, and the rename dialog will come up. (I think that Move does the same thing, and perhaps Duplicate as well.) Type in the new name, and press Enter. Then save the file.

So it is a bit more complicated than you might think, and I think that there were some earlier versions of MacOS where it did not work at all, but it seems to work now.

I use this quite a bit with Preview when I print a PDF or use Print Preview.

That does not work here (macOS 10.14.3).

I am using the rename feature in other apps like, too, but it is working easier there:

  • You can directly click the file name, and the Rename dialog comes up.
  • Or you choose the Rename menu item, and then the file name in the window title bar is editable at once.

The Move menu item has its own dialog (without a renaming option), and the Duplicate menu item creates a second document window with the file name editable in the title bar.

Well, I do not know why it is not working for you, but Rename definitely works for me.

Same macOS version?

MacOS 10.14.3

For me in OS 10.13.6 the Rename menu item does nothing at all. I can get the rename dialog to come up on any form or procedure window that has the down arrow next to the window name by clicking in that area. That seems to be for everything except the data sheet in Panorama X. The down arrow is available in forms in both data and graphics mode. This also allows for moving the file to a new location which is a handy feature as well.


The Move To… menu item opens a dialog sheet in the active window while the Duplicate menu item simply opens a second copy of the active database with “Copy” added to the name with no dialog at all.

I can confirm this in macOS 10.14.3. The down arrow is missing in the title bar of the data sheet.

Also using 10.13.6. Choosing Rename causes the name on the title bar to be highlighted. I can then type a new name, and the name changes, there and in the Finder. There isn’t any dialog.

05%20PM 28%20PM

Very strange indeed that we are both running the same OS and have different actions. I just noticed that if I open a new unsaved database that using Rename in that data sheet opens the rename/move dialog as a sheet dialog.


I have not seen the file name in the title bar highlight as you are experiencing. To quote Bill and Ted: “Strange Things are afoot at the Circle K!”

I believe that’s a Save As… dialog. Just like the one you would have gotten if you had chosen Save, when you didn’t already have a file on the disk.

The odd thing about all of this is that there is not a single line of ProVUE code for the rename feature. This feature is provided entirely automatically by Apple’s system code. Since I haven’t written a line of code for this, it is very difficult to get a handle on what I might do to change or fix the way this works. It’s especially odd that different users are reporting different outcomes even when they are using the same version of macOS.

Hadn’t even notice that - makes things even stranger when the Rename opens the Save AS… dialog.

Probably not worth the effort since it looks like Apple is playing games under the hood anyway.

I think that’s standard. If I use “New from Clipboard” in Preview, to create a new unsaved file, and then I choose Rename, I also get the Save As… dialog. The same thing happens with a new unsaved file in TextEdit. It needs to put a file on the disk before it can name it.

After reading here, I tried a few things: The down arrow shows in forms all the time if you mouse over the window name, but I have to choose File>Rename in the Data Sheet to change the name. Then the name at the top of the Data Sheet becomes editable.

As I said before, I recall having problems with this in earlier incarnations of the OS. I do not recommend staying on 10.13 unless you have a computer that will not accept Mojave. If you do, you can stay with Panorama 6 until you have to upgrade your computer.