File menu glitch

I doubt the menu is supposed to look like this.


Did this just start happening? Did something change recently on your system? What version of macOS are you using?

You might try downloading a fresh copy of Panorama X.

Well, restarting Panorama seems to have fixed it, but it should be of interest that that can happen at all, surely.

Unfortunately I didn’t think of it at the time, but if this ever happened again it would be of interest to know the result of the formula


You can easily run this formula this by opening Help>Formula Wizard and typing the formula in. The result area will show you the internal template used to create the File menu and it’s submenus.

At a lower level, the menu is derived from this template file, so that would be interesting also.


Based on the symptoms, it kind of seems like a dozen lines of this template were missing. But this is just a text file inside the Panorama bundle. My theory when I suggested downloading a new version was that somehow this file got corrupted. But since just a relaunch cleared it up, apparently not. Maybe a caching problem?

If the suspect dozen lines were missing from the template, that would mean that the Import, Export and Revert submenus would be missing. I don’t supposed you noticed whether those were missing before relaunching?

This may have nothing at all to do with it but this afternoon, when I opened the Help wizard and tried to type into the search box. it wouldn’t accept any characters, beeping every time I tried to enter one. Closing all other windows allowed me to enter characters but the display was awry, with the main window empty until I selected a topic from the list.

Quitting and re-opening didn’t change that behaviour, nor did reloading Panorama X. Shutting down and re-booting the computer fixed it. I have never experienced anything like that before.