File can't be saved - doesn't exist

Has anybody yet worked out why this happens? I get it a lot and it’s very frustrating.


I guess that’s a no.

There is a discussion of this problem here with a suggested solution:

I had period where this problem occurred several times. I used something like the steps described in the link that Gary posted, which seemed to work some of the time. Fortunately it has not recurred in a long time. Unfortunately, I don’t understand why it started or why it stopped.

Thinking back, I recall having this come up some time ago and I believe I simply did a Save As… and had it replace the existing file which is what the Save would do anyway.

I don’t think I’ve tried that - although trying the Duplicate command still gives the error message - isn’t that essentially the same as SaveAs?

It is similar but not the same. In order to duplicate a file the OS needs to know the correct path — and the mentioned discussions post said that a path corruption was the reason of that error message —; but if you use Save As … you will enter a new path yourself with the Save As … dialog.

You know you get the Save as … menu item back (in apps that are normally using the Duplicate menu item) when you hold the option key in the File menu?

OK, thanks Kurt.

I knew about the option key but I now have SaveAs as a permanent fixture in all apps - can’t recall how I did it, maybe an OSXDaily tip?

Here is the TidBITS article you are thinking of. It explains how to permanently bring back Save As to all modern Mac applications, including Panorama, by changing system preferences. This article is 4 years old, but this still works.