"file can not be saved, because it doesn't exist"

Jim, thanks for all your effort that went into Pan X and the state it is in now. For my simple requirements it is already a viable DB, especially with the forum and the experts available there in emergencies.
There is one recurring nuisance, however, which pops up unpredictably, now less often than before, but I am still occasionally faced with the text above in a pop-up window. Last time it happened, I was afraid to lose several days of work. When this happens I have to force quit PanX but duplicating the file in question and opening the copy with PanX usually solved the problem. Not nice but it used to work. In this last case it did not.
Finally, in desperation, I tried “alt-save” (= save as) and the file was saved (not duplicated), with a slightly different icon. After that it worked again.
What worries me is the unpredictability of this error. I don’t know why it occurs, I can not reproduce it at will, it just happens occasionally. Usually, when I want to save modifications to a file which required a lot of detailed work.
Do you have an explanation?
Have latest PanX, latest Sierra.

There was a thread last fall about this topic. This is not a Panorama problem, it is a system problem, most likely whatever folder the file is in does not have the correct permissions. That error message is not a Panorama error message, the message comes from Apple’s code. (Panorama X relies on Apple’s code to a much larger extent that Panorama 6 did – for example all reading and writing of databases is handled by Apple’s code.)

After going through the discussion in the thread you refer to: I have my files under Documents, as should be. I also have the ClamXav virus protection program running. Could that be the culprit?

I don’t think so.

When you say you have ClamXAV running, you mean the ClamXAV Sentry, don’t you? Even if you have configured it to monitor your Documents folder, it should not be in the way. But you can easily test your suspect and remove the Documents folder from the Sentry’s folder list.

(The above screenshot shows my preferred setting. I prefer to scan the Documents folder manually.)

If you were not talking about the ClamXAV Sentry, then ClamXAV does nothing at all in the background, only when you start a scan manually or when you have scheduled some tasks.

I don’t know anything about ClamXav.

However, if you google for could not be saved. the file doesn’t exist you’ll find lots of hits involving many other Mac programs, including for Apple programs like TextEdit. That’s why I don’t think it is a Panorama problem, but rather a general Apple problem. If you do the same google search hopefully you can find something that will help track down the problem.

I have had the same problem but it is gone now… Here is what made it go away on my Mac.

  1. Turn off --> auto save every XX minutes

  2. With the newest MacOS my Documents and Desktop files are being saved to The Cloud.
    I believe this was fooling Panorama’s temp files.

Anyway… that fixed my "File cannot be saved, because it does’nt exist.

YT… Jb.