Field sizes of records are huge in converting to Pan X

I am not sure why this is happening, but converting a Pan 6.0 to Pan X causes the width of the fields to be extremely wide, running way off the edge of the window. I need to slide the vertical button way over to the right the find the end of a field and then click on the field and move it back left to make is the original size. Has anyone else seen this happen and if so, is there a quick way of resizing fields? The image below is for a field Name, which is maybe the 6th field of 22 or more. Below that is what it looks like in Pan 6


Update: I saw where I can go into Blueprint and change the width for each field. Turns out I have 13 fields. In Pan 6 in the Design Sheet, the width are all just enough for the size of the record entered and I think the original size was automatically determined by the size of the field header.

I hope this explains what I am asking about.

For me, the text in the Pan 6 database is much smaller than the text in the Pan X database. Field sizes are wider in Pan X, but only in proportion to the text size.

For what it might be worth, here is a little procedure that will change all the field widths to 20:

local thefields
looparray thefields,¶,element,item
    field (element)
    setfieldproperties initializedictionary("WIDTH",20)

I would do a Formula Fill on a Numeric field to see wha the width is of that Name field. I’m betting that you’ll find that one or more fields have some excess blank trailing spaces. (Or you could do a Trim on that field). In Pano 6, the field is not going to expand to see those spaces but bringing it into Pano X will cause the field to be the width of the widest cell.

My guess.

Robert Ameeti
(949) 422-6866

I may have to do some further explaining. I created the database in Pan 6. I then added the .pan to the end and then opened it up in Pan X. Should not all the fields come in the same way as in Pan 6? I must be doing something wrong.

@Pete The field widths in Panorama X should be very close to the field widths in Panorama 6. There must be something different about your database that Panorama X isn’t handling properly. The blueprint thing is a good workaround, but I would like to fix the underlying problem. If you could send me the database (the Panorama 6 database, I don’t need the X version) I would like to take a look at it – be sure to include a short description or a link to this thread to remind me what the issue is.

Ok, will do. I am guessing something is wrong on this end, as I don’t remember having this issue earlier on in August when I converted some files. I will send it directly to you?

Pete, I am puzzled. I tried the file you sent me, and the field widths are the same in Panorama X and Panorama 6. In the screenshots below, I did nothing except open the file in each program and resize the windows so that they would fit in the screenshot. I did not adjust the widths of any field.

As I said, it is probably something I am doing wrong for some reason or
another, as I don’t recall this happening to me when I did some
transferring of Pan 6 files to Pan X in August. I will work on this
and get back to you after i figure out what I am doing wrong.


Are you still using the same operating system you were in August?

Yes, I think so. OS X El Capitan Version 10.11.5

Well, maybe the version number has changed since then, but not the OSX.
I haven’t moved up to the new one yet.

Best wishes,


Wow. Didn’t realize my emails became public. Sorry about that. I hope I can delete some of the private stuff.

Well, I decided to try and drop the Pan 6 Icon onto the Pan X Icon and bingo, all is fine. Magic. I wish I was always this smart…

I was going thru old posts and noticed this – I now know what the original problem was! Turns out, Panorama X would not import the field width properly from a Panorama 6 database for fields that were hidden in Panorama 6. I guess Pete must have done a Show All fields before he sent me the database, since I didn’t catch it originally.

This is fixed for the 0.1.029 release.

Yes, you are correct in that there were hidden fields originally that I didn’t notice until later (that they were hidden). Did not connect the two issues. I guess when I dropped the Pan 6 file on top of the Pan X file, all the fields were picked up, as I indicated to you that it then worked, probably because I noticed I had hidden fields and then showed them all before dropping the file on Pan X. Can’t remember that far back. Thanks for finding this little bug. Boy, you sure can do the detail stuff well.