Enterprise Server not updating procedures

Trying to update procedures in server copy of a bunch of shared files. I’m using the DB Sharing Options Wizard, with my file open, selected, etc., having made changes to procedures and saved them. When I click the “Update Procedures” button, or select from the pulldown menus, I get a dialog that says “0 procedures updated” and, of course, the procs are not updated. I’m pretty rusty here, but I thought that was all there was to it. Do I need to do a new generation? (I try to avoid that step, if able). Thanks!



Just in case the procedures have actually been updated, make another minor change. Then use Update ALL Procedures and see what happens.

A sign that you don’t have a connection in the first place is the failure to new asked for a password when you select the databse to be updated.

If all else seems to be failing, a restart of server and client can be the difference.

Thanks, Jim.

By that measure, I know I had a connection, as I was prompted for my pw several times. (Plus, the server was open on the monitor next to me). I made several incremental changes, with a save and then an update command in between, but got the “0 proc updated" message every time. I will restart and see what happens.

If it still doesn’t update, I’ll just try a NewGeneration. (?)


It is my vague recollection that the Update All Procedures works only for Web Publishing stuff. It does not work for general Local or Remote Sharing.

That is correct. I assumed (wrongly) that prior use of the Update processes had worked so didn’t ponder shared files versus web published files.

Not sure I’m aware of that distinction. Again, I’m a little rusty, trying to troubleshoot a procedure I haven’t looked at for a couple years. In this instance, the database is set up to be shared locally, over the internet, and in web publishing, as indicated by the checkboxes in the Database Sharing Options Wizard. Is there any more to it than that?

Because the client computers all need your new procesudes, in your situation you want to use the New Gernation using the download and reshare options. The clients will all get notice to download the new version. They click okay, their copy gets updated and they go back to work. Works great.