Enterprise: Fixed Point Overflow

After doing a ‘New Sharing Generation’, one of my shared files was ready for editing. I added another ‘Choice’ in the Choices field and attempted to Re-share the file. The result was ‘Fixed Point Overflow’ when I did the Re-share…

I tried this on another computer, restarted the Panorama computer, and also restarted the Enterprise Server computer. Continuing to get the Fixed Point Overflow when I attempt to get this file back on the server. I’ve removed the file from the server as well. Attempting to upload a Force to Single User results in same error.


I’ve never heard of anything like this, and no idea immediately comes to mind.

Not that it should really matter, but approximately how many choices are there for this field?

If I encountered this problem, I suppose one thing I might try would be to force the file to single user, then try sharing it. Oh wait, you already tried that.

If you create a minimal test database and share that, does that work?

The choice that I added was a 4th choice to an already existing 3 choices.

The file is one of ~8 files in a collection.

Ok, I just wondered if it might be one of hundreds of choices.

Unfortunately, I am stumped. Did you try uploading a new test file?

I first tried to do this on a computer local to the server. The failure occurred. I then repeated it on a remote computer doing the same actions. Repeated failure. They each had their own shared files.

Have you tried changing the field to a text field, and then back to choices? I have no idea if this would fix it, but it is one of the things I would try.

The fix was to take a previously working copy, Force to Single User, Export all records but 1 single record, Delete the previous copy from the server along with any extraneous copies, Upload as a new file to the server with the single record. This was successful. I then did a ‘New Sharing Generation’ and while in Single User mode, I imported the previously exported data back into the file. When I then Re-Shared, all was ok.

(Side note… Before doing all of the above, I did every kind of analysis I could think of on the original Shared file to find some type of corruption but found no problems at all.)

Wow, I can’t imagine why that was all necessary, but I’m glad you are back on the air.