Duplicating Field Bug

Using PanX version 0.1.029 (2214) on Mac OS Sierra version 10.12.2.

I have one database where I’m trying to duplicate a field. Each time I invoke the Duplicate command the Pan gives me a spinning beach ball of death. A force quit is necessary and this keeps repeating.

I’m actually trying to split a field and keep the original field as well. I know you can also check a box to keep the original field in the Split Field Sheet. However when the sheet is invoked the Cancel button is covering up the checkbox. I tried dragging the sheet to a longer dimension but that doesn’t force redraw the sheet properly. See attached photos.

Unfortunately I can’t duplicate any of the problems you are experiencing. Here is the Split Field dialog on my computer, also using version 0.1.029 (2214). There is a display bug, the bottom of the dialog is empty (I see that in your screen shot also), so I’ll need to take care of that.

But otherwise the dialog is ok. Does anyone else see the same problem with this dialog that Rico is seeing?

I also couldn’t get the Duplicate Field command to fail. I tried it on several databases, including this one with 80,000 records. It took about 10 seconds to complete, but it worked properly.

You say this is repeatable, maybe it is something wrong with the database itself. If you are willing to send me the database I will try it and see if I can duplicate the problem. If you do that, be sure to send me exact instructions, in this case what field you are trying to duplicate (and anything else I need to know).

You can also duplicate a field manually, first by inserting a field and then using the Morph Field dialog.

Does that work for you? If not, at what step does it fail?

Yes, exactly so on my MBP 13" (mid 2012) with macOS 10.12.2 .

I did some more testing – with funny results:

  • First I tested the same database as before after a restart of my Mac. Found the same problem in the same field of my database.

  • Tested another database: Worked perfectly without that display glitch.

  • Tested my first database again: The same field as before: glitch in the Split dialog.
    A different field: No glitch, all options readable and accessible.
    Back to the first tested field, active cell in the middle of the data sheet: No glitch anymore.
    Back to first tested field, active cell in the first record: No glitch anymore.

I tested the database some more and observed that it’s not just one field that causes a spinning beach ball. Every field has the same result. Once I select Duplicate Field I see the selected Field title change to Copy of … (although I don’t see two copies of the same Field, it merely changes the title of the original) and then a spinning beach ball.

I did try your method of inserting a blank field and then using the Morph Field command. That worked perfectly.

In preparation for sending you the database, I duplicated it and then erased all the records. Lo and behold, it now works fine. Is it possible that bad data is causing the crash? Can I email you the original file?

Certainly that is a possibility.

It’s odd that inserting a blank field and then using Morph Field works. That is really the exact same thing that Duplicate Field does! You can easily look at the source code for Duplicate Field if you want.

Can I email you the original file?

As far as I am concerned you can – otherwise I won’t be able to work on the problem. I never share any customer files I receive with anyone else and they are discarded when done. In 35 years no one has ever had a complaint in that regard, though at one time the CIA had a problem with OverVUE and they never were able to work out a way to let me look at the data!

Yes, on my 27" iMac with OS 10.12.2 and latest PanX. See photo below:

This was the first operation I did after opening the database. Subsequent efforts to repeat this problem without closing and reopening the database failed. After quitting and reopening the same database and splitting the same field - no problem. Very inconsistent - no pattern.

I have no problem with the Duplicate Field operation - works fine on 33K record database. I have no forever spinning beachballs.