Drop image per record doesn't show

After upgrading to Monterey, the different photo in every record doesn’t show anymore.

  • in the record design, the specific field is programmed as DROP[hfs ]Photo
  • the locator of the different photos per record if for example
    Heist:Panorama data:USA:Nevada:DSC09422.jpg

Heist being the name of the hard-drive, thus different fro Macintosh HD, my system disk.
What did I try and didn’t work:

  • replace the : by / in the file locator
  • dropping Heist: and putting the photo file on the Macintosh HD system drive

What should I do to see the individual images back in my +20,000 photo file?

The POSIX path to that file would be

/Volumes/Heist/Panorama data/USA/Nevada/DSC09422.jpg

Note, a full path begins with a slash. Relative paths do not.

Thanks for you suggestion, but it doesn’t work in my file.
Any other ideas?

Have you read this?

I can’t put all +20,000 photos into the same folder as there as the names/numbers are not unique, in other words sometimes I have +10 photos with the same name/number.

It worked for about 10 years with : in stead of /, without the word Volume upfront. If that is the solution, it would be easy to fix, but it is not the solution, I tried it.

“Volumes” ends in an s. Is that the way you wrote it when you tried it?

But you can drag at least one photo to see what path Panorama gives it. That should give you a clue about what issue exits in the currently entered path for the others.

Yes, I used volumes
Yes, I dragged one photo in the same folder where my Panorama file sits.

What I did since +10 years is a simple action: display that photo which sits in that folder on that disk in the field. The photo is small, about 40MB, as it function is just to give a visual feedback.
This is the part of the screen that I used for +10 years without a problem:

Thanks for engaging me to get to a solution

It is “/Volumes/”. Case, et al, matter.

By dragging a photo, the idea is to drag it to a field, or a cell. Even into another, temporary database will work. When you do that, Panorama will enter the path so you can see what it should be and compare it to the path you have that’s not working.

Your screen shot doesn’t provide anything to go by. You have a Name for an ImageDisplayObject that has no influence. The path is what matters.

BTW, 40MB is not a small image. I’ll guess that you mean 40KB which is tiny. I work with images a lot. I tend to use 200-400 K for thumbnails.

sorry, KB of course

I dragged the picture into The field and into another empty field and as soon as I lift my finger from the mouse ====> the picture–actually the name of the picture–flashes back to the file. No messages… I don’t see a path

HOLD ON! Miracle happened!!!

I dragged the picture into the field of the record table and it worked. More, All the definitions of the other +20,000 files, with the : and Volumes not specified helps, too.

I guess my error was to drag it into the record creating, full screen, lay-out.
Thank you so much.