Drag & Drop from Photos.app

I’ve always been able to drag and drop images from iPhoto to PanoramaX, and I just recently “upgraded” to Photos.app. Photos allows one to drag and drop to/from the Finder, but not to Panorama. Is there a way to authorize Photos (or Panorama) to drag images to Panorama? I’m using the standard DragReceiverObject with the dragimagesfromfinder command.

So are you saying you could drag from iPhoto to Panorama, but not from Photos to Panorama? I didn’t even know dragging from iPhoto was possible. I’m not a user of either iPhoto or Photos, so I don’t know the answer to this question.

Using iPhoto in Catalina, I’m able to drag an image directly form iPhoto to a DragReceiverObject just fine. So yes, it does work.

I made a Test in Mojave and created a new database with one field “ImageName”. Then I made a new form with a Drag Receiver and an Image Display object.

The Drag Receiver object with this code (taken from the documentation):

dropimagesfromfinder |||field="ImageName" skipduplicates=yes|||

filled the path to the dragged image into the field “ImageName”. The Image Display object was set up with the formula:


This worked with images dragged from the Finder as well as dragged directly from Photos.app to the receiver area, and the image was immediately displayed in the Image display object.

Yes, it has worked quite well in my Pan 6 database for a number of years now.

OK, well then I find that both hopeful and disheartening. Hopeful because it sounds like it will work when I upgrade to OSX 10.14, but disheartening because the two computers I’m using it on are maxed out at OSX 10.12.6 and 10.13.6.

As before on these two machines, I’m able to drag from the Finder but not from Photos.app.

Anybody want to try it out on a machine earlier than 10.14 to see if there’s something I’m missing?

I tried it on El Capitan 10.11.6. Dragging from the Finder works, but from Photos.app it does not.

Yeah, dang it. Thought so. Thanks for checking it out.

I can’t find a version of iPhoto that will run on either of my OS 10.12.6 or 10.13.6 machines. You don’t happen to know where I could find one, do you? All I can find is Photos.app.

Wiki says iPhoto was replaced, with the release of OSX 10.10.3, by Photos which would import the library from the former. The final version of iPhoto, 9.6.1, kept working at least into OSX 10.11. Earlier versions supposedly were disabled and I don’t recall how long 9.6.1 kept working. I do recall iPhoto was removed from the App store once Photos was released so I’d expect that final version to be hard to find. I don’t recall playing with drag and drop with either so can’t comment on your basic question.

Last week I was listening to the Mac Power Users podcast and someone claimed the last version of iPhoto would still work on Mojave, but not Catalina. They are usually pretty knowledgable about this sort of thing, so I suspect that is true.