Displaydata looping

This procedure, attached to a button, worked a few times. I added a couple of lines, which I have since deleted, and it went into an infinite loop of creating displaydata windows until I hit stop on the top window. After hitting stop, it freezes and I have to force quit. Even after taking out the extra lines, it still loops, even though it worked right previously.

 openurl "https://www.eftps.gov/eftps/index.jsp"
 opensecret "PASSWORDS"
 setactivedatabase "PASSWORDS"
 select «Name»="Fed Tax Payment"
 displaydata "Password: "+«Password»+cr()+"PIN: "+«UserID»+cr()+"ACCT: "+«Acct#»

Your code looks ok. I use displaydata all the time, I have never seen a problem like you are describing.

Sent a .mov file, hope it got through.

If I move the openurl statement to the end of the procedure it works fine. Of course, I have to click the displaydata button before it will move forward.

Tried the procedure in several files, always the same result. Need to try it at home on a different OS.

Update: Tried it at home with El Capitan,after Force Quit, new empty file with no other files open and still get the same result.
When I hit OK on the first displaydata window I get the message “Field or Variable MessageImage does not exist” and that window closes. I click ok on the next window and I get the message “Resume statement failed (No Pause)” and window stays open and can’t do anything in PanX, other than move windows. The Force Quit window doesn’t show PanX not responding.
With nothing in the file which holds the procedure, if there is a problem it would have to be in the Passwords file, which shouldn’t generate anything as it is opened Secret. The Password file at work has been updated many times since I last did the one at home, but still get the same issue.

I’m guessing you did this as an attachment to an email submission to the forum, not using the forum web interface. The forum software ignores email attachments.

What if you completely remove the openurl statement?

The openurl statement is going to make your browser the active application, maybe that has something to do with the problem. If you want to display a web page, perhaps you could just display the web page in a form using a Web Browser object?

In that situation try pressing the ESCAPE key. If that doesn’t work press FUNCTION-ESCAPE key, that is sure to close the stuck dialog and get you on your way.

Emailed it to webmaster@provue.com.

Completely removing the openurl statement does solve the problem, but the point of the exercise was to open a url to enter things, not merely to look at it.

I did try opening a different url, incase the page was the problem. Got the same result. I have a couple of other procedures with openurl and they have not given me any trouble.

Martin McCaffery


That should go to me, not this group … ok, I found it. For future reference, this isn’t a good way to send stuff. Any email sent to me with the subject starting with [Panorama Discussion Forum] is automatically routed to a folder where I normally would never see it.

Ok, I see what you were going for. My suggestion stands, in fact more so. I would suggest creating a form that displays both the web page and the password, PIN and Account number, all right in the same form. The Panorama Web Browser Object isn’t display only – it’s a complete browser right inside the form. So you can certainly go ahead and enter items into the page, just as you would in Safari.

By the way, I just noticed that you have selectall followed by select. In this case, the selectall is not necessary, it’s just burning some CPU cycles to no effect.

In fact, you could just say

opensecret "PASSWORDS"
displaydata superlookup("PASSWORDS",{Name="Fed Tax Payment"}.{"Password: "+Password+cr()+"PIN: "+UserID+cr()+"ACCT: "+«Acct#»})

Or, if you followed my suggestion of creating a form, you could just include the superlookup( formula in a Text Display object.

Ok, thanks. I will give it a try.
Martin McCaffery