Different Behaviors among High Sierra, El Capitan, Yosemite

I have a procedure that creates a variables that fills in a Text List Display, and some other variables for Text Display. I have it working as expected on my new work computer which has High Sierra. Made a copy to bring home and try on my older computer with El Capitan, and my laptop with Yosemite. This procedure ends with:

Show variable [variables]

noshow is disabled as such “;noshow”. I don’t plan to leave it that way, just left over from debugging.

With High Sierra, the Text List and Text Display objects display as intended at the end of the procedure.

With El Capitan and Yosemite, the TL and TD flash on and then off at the end of the procedure.

However, if I reenable noshow by taking out the semicolon, both El Capitan and Yosemite computers the TL and TD continue to show the variables.

The strange part is, if I re-disable noshow with the semi-colon, the variables still display properly until I save the change or close and restart the file. It’s not necessary to save the procedure the get no show reactivated, just de-activated.

I don’t know what to make of this, but thought I’d throw it out that as another one of those weird inconsistencies.

I’m having a very difficult time following what you are trying to explain.

However, I can tell you that noshow and endnoshow should not have any effect in this situation. Of course they may affect other code you are not showing us, but the showvariables statement will ALWAYS update the display of the specified variables.

The noshow statement only affects operations that change database fields. Normally changing the value of a field automatically displays that change immediately, using noshow turns off that automatic display. Since changes to variables aren’t automatically displayed, noshow has no effect on them.

I’m wondering about your line

Show variable [variables]

I’m assuming the space after show is just a typo on your part, and that you aren’t actually using a show statement, but rather showvariables (with an s on the end).

Yes, just a typo on the showvariables (rather autocorrect).

So, I’ll try again.

I have a procedure:

showvariables [variables]

If I run this in High Sierra the variables show on the form and stay, but in El Capitan and Yosemite, the variables show on the form briefly and then disappear.

If I change the first line to “noshow”, there is no change in High Sierra (as far as the variables behavior), but in El Capitan and Yosemite, the variables show on the form and stay.

Then there is just the behavior working depending on whether I save or not, which I described previously.

I haven’t tried this in a simplified version, nor have I noticed it yet in other files.