Design Sheet updated version

Well, I had promised myself that I was done with the Design Sheet project and would not do anything further to develop it. So much for that thought. I received a nice note from James Cook with a really interesting suggestion to incorporate an additional worksheet form where you could edit all of a field’s properties in one consolidated place. James was also nice enough to include a template for this form so I decided to go ahead and implement it into the Design Sheet project. I have updated the files and reloaded them to my site where you can download the new version. There is now a new Worksheet tool in the ToolBar as well a an entry for “Go to Field Worksheet” in the Special menu.

Available at:

Just a note (nit?) about the documentation: I notice a couple of places where “Deign” is used instead of “Design!”

Sorry, but I have no chance to use the Field Worksheet on my 13" MBP, because my screen ends with the vertical divider next to “Delete All”. And some automatic window resizing prevents me from pulling the window edges wider.

No doubt Gary will deign to acknowledge your comment:-)

Well, either I have a sticky keyboard or some weak fingers. I have corrected those typos in the docs - thanks for pointing them out. Spell checkers aren’t much help when your typo results in a legitimate word. :disappointed:

You can always activate the new Field Workshop form from the Special menu. I don’t think there is any way to force the floating ToolBar window to scroll along with the datasheet window. Gosh, it was already hard enough to get them to move and resize together!

I am seeing a similar problem on my 13" MacBook Air. The toolbar goes a bit off the edge, and the bottom of it is cut off, so I cannot read it.

Ok, maybe I can adjust the ToolBar tools to compress them to fit some smaller displays. It would be helpful to know the resolution your MacBooks are set to before I undertake this. I’m guessing these are the older models with resolutions of 1280 x 800.

Yes: MBP 13" (mid 2012) with 1280 * 800 px.

My mid-2013 MBA is 1440 x 900.

Ok, I’ve reduced the size of the ToolBar so all the tools should now be visible even on the 1280 x 800 screen. I also reduced the default column widths slightly but they will still have to be scrolled to get to the far right columns. I don’t think there is anything more I can do with this to reduce the required screen real estate. Folks with larger displays can of course resize the forms to better suit their needs. I have uploaded the new version:

Still not working. The bottom of the toolbar is truncated.

Thank you, Gary! Now it works on my 13" MBP (1280 * 800).

Bruce, the reason is that you somehow have managed to activate a Tab Bar in your Pan X windows. How? I can’t find a menu item for that in Pan X.

Yes, Kurt is correct in that the problem is due to the added tab panel you have showing. These are new to Sierra and controlled from the Preferences’ Dock panel of all places. You probably have tabs set to “Always” and if you switch them to “Manually” or even “in Full Screen Only” they should not be created automatically every time a new window is opened. You can try to drag the ToolBar tab panel off the window to see if that removes it.

This is how it is set. I have never changed it.

Then it is a total mystery to me as to how those tabs are being created. :confounded:

I finally see were these tabs can be triggered. Shift-command-T seems to toggle these tabs on and off. It is also available in the View menu.

Now that this problem has surfaced, it might be the right time to request an additional option be added to the various statements that set up new windows. “NoTabs” would be a nice addition to the various existing options ("NoScroll NoToolBar etc.). I found this topic discussed on stackoverflow with various solutions for implementing this option on a window by window basis.

1 Like

Not it!

I assume you are in macOS Sierra so I have no idea why that View menu choice is grayed out or how to force the tab bars to close.