Database options sheet broken

When I tried out the db options panel, first:

when I tried to open it, I got this alert: Dialog program error—dialog will be aborted.
I ok’ed out of that and the options panel opened.

Next: I added an auxiliary db to the db in question; but when I clicked OK, I got this alert: resume statement failed (no Pause). At that point I couldn’t get rid of the options sheet; clicking either cancel or OK got that same alert. I was able to get out of it by switching to another form in the db and closing the db entirely. When I reopened the db and then opened the db options panel, (after the first dialog program error was ok’ed out of) the auxiliary db I had tried to add did not appear on the auxiliary list.

I’m on the latest beta and still running Catalina.

It sounds like there’s something about your database that the Database Options code doesn’t like. Does this happen for any database? or just one particular one?

The instrumentation feature I discussed on Thursday may be able to help track this down. Please make sure that Instrumentation is enabled on your computer as I described in the session – if you need a refresher here is the help page:

Then clicking on this link will enable instrumentation coverage for the Database Options dialog.


Once the instrumentation coverage is set up, open the Database Options dialog. Then send me the log this produces (you can email me or post it here).

Well, this morning, when I restarted PanX and tried it again everything worked as expected. I guess something had gotten flipped in RAM.

One little item: when I set an Auxiliary relationship, the red dot doesn’t become “dirty”, so there’s no reminder to save your work; you have to remember, otherwise the new relationship doesn’t stick. Not urgent but would be nice to have fixed…