Data base hanging

My main database opens but is hung. I can’t select or sort. I’ve been using this DB for years. This is a new development. is there any way I can get it to operate so I can export the data and start a new db? When I try to do a Find/Select a blank window opens up. I remember this happening when I switched to Panx, something about a missing font. Please remind me how I check/fix this. Has something changed with the latest Mac OS update? This database is about 125mb. My backup from last week and my back up from the first of the month are all operating the same now.

Mac OS 10.15.6

Thanks Bill

There was a bug report a few years ago that the Find/Select dialog would not work if the Verdana font was not installed on the system. We were never able to track down this problem, so it may still be a problem. Verdana is always pre-installed on all Mac systems, so normally this should never be an issue. But you might check for that.

The Find/Select dialog can also be affected by corrupted preferences. There is no way to uncorrupt them, but they can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

Sorry to say that didn’t work for either problem. When I open this DB it looks like all the info is there but I can’t select any record, it opens frozen. Any other thoughts?
Thanks Bill

Try saving the database as a text file and import that into a new empty database. If you have lots of procedures or forms, you can veert easily copy them from the old d/b to the new one using the View Organiser.

One thing that is not clear to me – do you have other databases that work ok? In other words, is this a universal problem with all databases, or just this one particular database?

If you don’t have any other databases, please try creating a new database and see if that works correctly, or download a database from the Help>Panorama Database Exchange.

My other DBs work just but they are smaller. The DB I’m having problems is about 80 parameters with about 20,000 entries thus 120 mb. My other DBs are about 30 parameters and about 400 to 1000 entries. They seem to work just fine.


The size of the database shouldn’t matter. If you would like us to take a look at it please compress the database into a zip file and send it to support AT, with a short description of the problem.

I was able to examine this database. The problem appears to be that the database was stored on iCloud and used on multiple computers. In the process of trying to synchronize the changes between multiple computers, iCloud corrupted the file. I got lucky and was able to extract the data and rescue the forms and procedures, or at least I think I did.

This is the reason I am working so hard on getting Panorama X Server ready.

Just to say this “hang” sounds to be what I’ve reported several times in the past. For what it may be worth let me add a little more detail.

Having a database that I’ve used for a number of years just suddenly “freeze” seemed to happen fairly frequently after I initially moved it to Panorama X shortly after that version became available. Your “corrupted preferences” fix (as you describe above) “unfroze” the database on at least some occasions. Other times I had to revert to a saved copy.

This problem has become quite infrequent and I’ve had this same database “freeze” only once in recent months. On that occasion refreshing the preferences file did not revive it but I recovered it from iCloud.

I can report that other databases operate normally if opened at the same time my main database is frozen. With an active problem I’ve been quite hesitant to open other databases until I’ve resolved the problem and have only done so occasionally to see whether the problem was global or only afflicted the one frozen database. I’ve not experienced a “freeze” while running any of my dozen or so other active databases but I run then quite infrequently.

I’ve never experienced a frozen database upon initial opening, only while actively doing data entry, sorting, scrolling, or the like. I can’t tell that any particular activity is associated with freezing, only that it occurs quite suddenly right in the middle of an activity. At that point after closing and reopening the database looks normal but remains frozen where it had stopped before.

I have only one copy of Panorama running on one iMac computer so iCloud shouldn’t be trying to synchronize across platforms I wouldn’t think (I do have a second MacBook and and an iPad, which iCloud does recognize but I don’t have Panorama installed on the other computer) I run Panorama from a local disc and adhere to your earlier recommendation not to run the database from the iCloud copy. I do save the database to a copy on iCloud, however, and as a last resort have been able to recover the “frozen” database from an earlier copy on iCloud.

The only advice I can offer is to save the working database as well as a backup frequently. Interestingly on at least one occasion closing the frozen database and reopening it from the local drive has worked. Most often, however, the local copy will not run and I revert to the saved iCloud version.

Thanks, Lynn