Creating form with Construct

hello all,

Strange problem with View>New Form and then Construct>Fields and variables. I’m trying to import a very basic Contacts db, it has some 20 odd fields and 550 names but whenever I try to create a new form (as above) Panorama quits.
I even went so far as to delete all the contact and only keep the field headings but the same thing happen.
Tried filtering data for diacriticals and such, went over the field names one by one, restarted Pan and even restarted the Mac.
I’d be glad to give anyone a copy of the data sheet with the headers.
Thanks for reading this.

I have been having the same problem. I am occasionally able to overcome it by not selecting so many fields, and then it will construct the Text Editor Boxes, but I cannot edit them reliably.

I suspect I will have to make a new file and import the data.

Compress the database to a zip file, then email it to support [at] I would definitely like to take a look at this. Internally, the Construct dialog creates new form objects EXACTLY the same way that creating an object manually does, using the same internal code, so there should be no difference. It will be very interesting to see if I can duplicate the problem you are seeing.

Hi Bruce,
Could you give this a try?

I’ve been playing around with this Construct thing and I’ve noticed that if I pick any 12 (or less) fields everything seems to work. I’ve tried from the beginning of the list, the end and a mixture.


I do not get as far as being able to pick the fields.

I sent the file to Jim, and he saw the problem. He suggested removing a procedure. I tried commenting it out; that did not work. I tried that and I was able to get it to work. I tried renaming it and that got it to work. I renamed it back and it worked. I did that with another procedure with the same results. Sometimes it will work with 2 empty records, but not with 1. There does not seem to be any logic to it.

Another problem I have had is crashing when I selected a certain number of form elements in graphic mode. That number may be 12. I do not recall.