Converting old Pan6 dbs

I have an old Pan 6 db which I would like to convert to Pan X. I’ve converted numerous Pan 6 dbs in the past, but this one is proving difficult. It is identified in the finder as a Unix Executable File, not as a Pan 6 db. Does anyone have some tricks which would enable me to convert this to a Pan X db? Thanks.

Have you tried adding the .pan suffix to the filename?

Yes. That was the first thing I did. However I received a message that Panorama was not able to open that file type.

Could this be an old file, that was never actually saved by Panorama 6? Pan X can’t convert a file that was last saved by any version of Panorama before Pan 6.

If that’s the case, it needs to be opened in Pan 6 and saved.

1 Like

No, it was a Pan 6 file which had been saved. However, how could I open a file in Pan 6 when I now have Pan X?

If you have an operating system that supports 32 bit apps, or access to one, you can run both Pan 6, and Pan X.

Are you sure it wasn’t last saved in Panorama 5.5, 5 or earlier? That’s what Dave means. Panorama X cannot open databases last saved in Panorama 5.5 or earlier.

If you really did last save it in Panorama 6, then it has become corrupted/damaged since the last time it was saved. There could be a problem with your hard drive, or a problem copying it from an older computer. If that’s the case, you’ll have to find an undamaged version. You won’t be able to open the damaged copy.

If you don’t have macOS 10.14 or earlier, you won’t be able to.

If you do have macOS 10.14 or earlier, you can still run 32 bit applications like Panorama 6. In that case, you can simply run Panorama 6, then use the File>Open dialog to open the file. Or you can simply double click it.

I think I’m this is just a SOL situation. Thanks anyway.

Do you have a backup of the file, to see if it is corrupt?

If you did not save it with Pan 6, you might be able to try an emulator that will run an older OS.

Since the file in question is labeled Unix Executable, I think it is corrupted and hence unsalvageable. Thanks to everyone for your suggestions.

You could try to open the file in a text editor and then you might be able to see most of your data scattered within if the file is not totally corrupted.

Are you sure you added .pan to the end of the filename? I was able to take a Panorama 6 database, remove the .pan from the end, and the system thought it was a Unix Executable. I don’t think the Finder looks inside of the contents of the file to see what it is – all it cares about is the extension on the end. If there is no extension, it thinks it is a UNIX executable, full stop.

Also, please make sure that you have the Finder preferences set to display all extensions. Otherwise you are just guessing.

Thanks for the tip. I already had the Finder set to show all filename extensions. I put the pan filename onto the file. It then looked like a Panorama db, which was significant progress. However, when I tried to open it in PanX (Version 10.2.0.b33 (4268), I received the following message: “File “tracy2excerpte.pan” does not contain a valid Panorama 6 database.” Any other suggestions I might try? Thanks again.

That’s the error you get when you try to open a database that was saved in the Power PC format by Panorama 5.5 or earlier. It can also happen, if the file was corrupted, and Panorama can’t find something that has to be in that file, if it’s a valid Panorama database, saved in the Intel format.

After opening, and saving with Panorama 6, I can then open in Pan X.

If it can be opened at all, you will need Panorama 6 to do it.