Construct form programmatically?

So the Fields and Variables form constructor is very cool. is there a way to invoke it in a procedure so it is automated?

Yes there is.

This is actually the code that the Fields and Variables constructor dialog uses when you press the Construct button, so the results are identical. The dialog simply provides a place for you to create/edit the template, then runs this statement, but you can do it yourself in a procedure.

When I use the Construct > Fields and Variables function, I get some weird behavior–

(1) beachball hell, causing me to have to force quit Panorama X; or,

(2) a completely blank form (and yes, I tried zooming out to see the whole canvas, etc – there’s nothing on the form).

Inadvertently I once chose the option for matrix/list which resulted in the beachball scenario…

Any idea what could be causing this?

There have not been any other reports of a problem like this. I use this feature regularly with no problem.

Have you tried this on more than one database?

Hi, yes, I have tried this on more than one database — I’ve even started a database from scratch and the behavior can be reproduced in a brand-new database, as well.

Is there anything I can send you — perhaps from the blueprint of the form — that would help to determine what’s happening here?

EDIT/UPDATE: Now, when I try to “select all” on form in graphics mode, Panorama X immediately crashes. :frowning:

It sounds like there is something really wrong with your installation of Panorama X. I have never experienced any of this, or heard of anyone else experiencing it. I just used this feature to create a new form yesterday, it worked perfectly.

Although the symptoms don’t match what you are reporting, a few users have had weird problems due to corrupted Panorama preferences, so resetting the prefs is worth a try, which can be done using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

If you’ve set up any options in the Panorama X preferences window, you will need to set them up again.

While you are at it, you might want to delete Panorama and download and install a fresh copy from our web site. Also, make sure that you only have one copy of the app on your computer. It’s actually ok to have multiple copies, I have a couple dozen copies on my computer, but then you may not know which copy is actually launching when you double click a database.

Is there anything unusual about your computer? What version of macOS are you using? Does Panorama X seem to be working ok other than this problem?

I tried all of these recommendations to no avail, but you’re right, it must be something with this particular machine because I installed on another machine and am able to use the Construct Fields menu item without an issue.

I wish I could figure out what is causing this so I can use Panorama on my primary computer, but I don’t even know where to start to diagnose this issue.

I will note that even after deleting Panorama and all of its associated files (using Clean My Mac’s uninstaller and on annother attempt, AppCleaner), subsequent installations of Panorama X did not require me to re-register/re-sign in to my account, so there must’ve been a remnant of the faulty installation somewhere that I was not able to remove when uninstalling the application.

Who knows what those apps do? I wouldn’t recommend using any app like that. Certainly those companies did not consult with ProVUE on how to remove Panorama from a system (though removing preferences is fairly generic for any application that uses the standard macOS preference system, as Panorama X does).

If you remove the preferences as I suggested in my last post, you most definitely will have to log in again, so this makes me think you somehow didn’t actually remove the preferences.

One other thing you could try is to create a new user account on your Mac. But I would definitely make sure you have tried removing the Panorama X preferences first.

You could look at what apps are on the “bad” machine that aren’t on the other. Specifically, do you use a VPN?