Close Database menu does not delete database submenus from View

After not being able to open various PanX files on the desktop by double clicking on them, I tried opening them from the File menu which led me to this behavior:

Example 1: Open PanX from the dock - a blank data sheet named Untitled appears. Click on the View menu to see the “default” View submenu. Now, select Close Database from the File menu. The window disappears and the View menu is still there. Select Data Sheet from the View menu - View menu disappears (you may need to click on View again).

Example 2: Open PanX from the dock and close all windows and databases so that the View menu is not visible. Select Open . . from the File menu and navigate and open the demo Property Listings file. The Property Listings:Browse window appears. Select the View menu to see the Property Listings submenu. Now, select Close Database from the File menu. The window disappears and the View menu is still there. Select Browse from the View menu - the Property Listings:Browse window opens again this time named “(null):Browse”. So, is the Property Listings database closed? Maybe. However, the tabs in the window work and changing the number of bedrooms and baths changes the matching properties.

Close Window under the File menu also results in the same above behavior.

When I close a database I do not expect the file submenus to still be listed under the View menu. I would expect the View menu to disappear or for the View menu to return to its “default” submenus.

It’s been known for two years that Panorama X menus don’t work correctly when no windows are open.

Pretty much the exact symptoms @Tom described were also described by @gary a couple months ago.

I’ve spent a LOT of time trying to figure this bug out, so far with no luck. At the moment, I have no ideas of how to solve this, ao I have put it aside for now. The good news is that you aren’t going to do any actual work with no windows open, so this problem doesn’t affect actual productivity.

There are some workarounds if you find yourself with no windows open – you can open About Panorama X, Preferences, Site License or Memory Usage in the Panorama menu and then the menu commands come back. Or you can click on the Panorama X icon in the dock – it will create a new empty file.

This sounds like something new – I have never heard anyone else report that. Are you saying specifically on the desktop, or any Panorama X file in any location on the disk?

Guess I should have put this on the bucket list but will continue here. I think we are talking about the same problem but the “no windows” behavior may be the end result and not the cause. Perhaps the Close Database command failed to completely close the database and reset the menu bar, including the View menu.

This may be helpful: closing a single database with Close Database, Close Window and Command-W on the keyboard all leave the just-closed database’s forms and procedures in the View menu. However, adding a one line procedure to the database of


and then running it from the action menu will result in the View menu being removed from the menu bar.

The PanX files did not open up on the desktop and did not open up at other locations on the the disk. I have not been able to determine a sequence of steps triggering this behavior. And now the behavior has stopped.

However, when it did occur it may have during a “no windows” situation. Once triggered a desktop icon would appear that it is going to open with the “flash/enlargement” of the icon before the window opens. However, the window never opens and the normal icon behavior seems to run in slow motion.

The other occurrence of this problem was when I opened a PanX file that had previously crashed in the graphics mode while experimenting with a Construct > List object. (Crash means both file and application close/quit unexpectedly, report window appears.) The file opened normally but every PanX file I tried to open after that did not open and presented the above mentioned behavior. Both desktop and other disk files were affected. Behavior stopped after I quit and restarted Pan X.