Clairvoyance (partially) not working for me

I have upgraded from Pan 6 to Pan X. I’m having a problem using Clairvoyance in the 2nd field of a database recording expenditures. Oddly enough all of the items in this field recognize Clairvoyance except for two, one called Home, Misc. and the other called Food, Household. Both of these worked fine with Clairvoyance in Pan 6. I have tried simplifying the heading, e.g. changing the Food, Household entry to Groceries. But I still can’t make Clairvoyance work for it. It’s getting so annoying!!! I figure there must be some simple solution, but I just can’t find one. Would appreciate help.

This is little more than a guess, without seeing your actual data. If you have an entry that begins the same, but differs only at the end, that could cause it. Clairvoyance kicks in when there is only one matching value. If for example you had an entry of

Home, Misc.

and another of

Home, Misc

Clairvoyance wouldn’t kick in until you typed the period at the end. At which point you would already be done.

A space at the end of Food, Household could also cause a problem, if it wasn’t present every time.

You might want to select those that begin with the characters you are expecting to trigger Clairvoyance, and then group up. See if you get two groups where you are expecting one.

Thanks for this - but I already checked to make sure that all those entries were identical. And after I replaced one set with a single word, Groceries, Clairvoyance would not work with the word Groceries.

The logic used by Clairvoyance is pretty simple. I think Dave is on the right track, there must be some other item in the data that is a superset of the word you are trying to type. If possibly, try sorting the database by this field and probably the similar data will pop out at you.

This reinforces my suspicion that there is a space, or some other invisible character after Food, Household. Changing “Food, Household” to “Groceries” would also change "Food, Household " to "Groceries ". There would still be a space at the end.

A formula fill with the strip( function just might make the problem go away.

Thanks Dave. Have not figured out the Food, Household problem yet, but a close scrutiny of Home, Misc revealed a period at the end of just one of hundreds of entries and when I removed it, that little problem was fixed, so thank you!


A formula fill with the strip( function just might make the problem go away.

Thanks. How would I try a formula fill with the strip function? I’ve not used formulas.

We’ve got you covered! Instead of needing to use a formula, since Panorama 5.5 you have been able to use the Morph Field dialog. This help page introduces that dialog.

This dialog has over two dozen transformations available for working with text, as described on this page. What you are looking for is to start with the Start with Field option and then use either Strip Surrounding Blanks or Strip Surrounding Punctuation.

The Strip Surrounding Blanks option is exactly the same as using the strip( function that Dave suggested, but without having to write the formula yourself.

To answer your actual question, to do a “formula fill” you would use the Fill with Formula dialog, which is in the Morph submenu of the Field menu (in older versions of Panorama this was actually called the Formula Fill dialog, which is why Dave referred to it that way). But I think you’ll probably find the Morph Field dialog is easier for you to learn, since you don’t have to figure out how formulas work.

Or you could use the Code property in the Field Properties Panel for each such field, with this sort of code (see Automatic Field Code in the Help wizard):

if A endswith " " or A endswith "."
	A = A[1,-2]

as shown below:

… and that would stop those two problems from ever occurring with new entries (the code strips off the last character if it is a space or a period). Just don’t forget to hit Enter before exiting the Code box, otherwise the code will disappear.

This solution won’t fix existing errors but it will prevent them in future.

Thanks but I’m a bit confused. I cannot find the ’Start with Field’ option, let alone the strip ,option.

PS Im still searching inside the ‘Morph’ dialogue and still cannot find my way to the ’strip’ commands

Thanks for help,


Please see the main help page for the Morph Field dialog, under Specifying the Data Source

Here is what Jim is suggesting:

Yes, that’s it. However, using the Strip Surrounding Punctuation option also strips spaces, so it’s not necessary to do both. For a Name field, Strip Surrounding Punctuation by itself is a good choice. I’m not 100% sure what @albion has in her field, she may not want all surrounding punctuation to be stripped, if not then she should use the Strip Surrounding Blanks option. Note that either way, punctuation and spaces inside the text is not removed, only at the beginning or end (there is another option if you want them removed inside as well).

Thanks very much, that worked. The visual demo enabled me to figure it out.

Thank you Gary for posting that – I do, however, want to point out for future reference that the documentation pages I linked to also have visual demos nearly identical to this. In fact, the documentation contains 696 “visual demos” – almost every feature with a graphical user interface has one or more of these.

Although the Morph Field commands to strip surrounding punctuation and spaces did apparently work to fix my problem with Clairvoyance, the problem returned almost immediately. I have just finished adding a lot of records to the database in question, and very strangely and frustratingly, Clairvoyance only worked on the field entries in question about 50% or less of the time. I returned to the Morph Field command to strip surrounding spaces a number of times, just in case I’d done something wrong. CV might start working again with the text in question, or might not. It seems to be working quite arbitrarily, All of these entries are in the 2nd field of the database in question. CV seems to be working in all the other fields. I would very much like a fix for this problem!!!

The quickest and simplest way to fix this is to send a copy of your database to one of us and we can find the root problem (rather than continually treating the symptoms). I’m happy to look at it if you wish - say so and I’ll send my email address in a message.

Michael, thank you very much, but It’s a personal financial database and not one I’d like to share.

I never had this kind of problem in Panorama 6, which always behaved consistenty if with less sophistication.

If you have any further suggestions that I can try for myself, I’d be keen to hear them.

Thanks again,


I think Panorama X is new for you, so naturally you assume the problem is Panorama X. However, Panorama X is not new, it’s been shipping for over a year and has accumulated over 120,000 hours of use since beta testers started using it in 2015. Clairvoyance is a popular feature, and it definitely would have been noticed if it wasn’t working reliably, or if it worked in any way different than it did in Panorama 6. In fact, the code for Clairvoyance was written in 2013, and has worked flawlessly since then, needing no modifications since Dec 6, 2013.

However, Clairvoyance is also a simple minded feature (and always has been). It’s not using AI or some fancy logic, just brute examination of all the data in your database. For every key you press, it scans every entry in the field for the entire database. If it finds only one match for what you’ve typed, it kicks in and offers the completion. So if Clairvoyance isn’t offering a completion, that means that there are still two or more possible matches to complete the entry you’ve started. The two or more matches are definitely there, because Clairvoyance found them. Again, it’s not guessing or using some kind of fancy algorithm, it actually found the multiple matches. In fact, the Clairvoyance feature is so simple it only takes up 14 lines of code (out of a total of over 200,000). It actually takes quite a bit more code than that to run the checkbox that turns the feature on and off!

For example suppose your database contains these two entries.


Clairvoyance won’t be of much use here, because even when you’ve typed in Grocer, there are still two possible entries. So while Clairvoyance is a nice feature, it isn’t always useful.

If you encounter a situation where you think Clairvoyance should be kicking in but it isn’t, a close enough examination of the data will show that there are two or more possible matches. If your database has a lot of data, it may be time consuming to track down exactly what the items are, but I guarantee the multiple matches are there – it is not acting arbitrarily. If you want to track down the matches, the best way would be to use the Find/Select dialog with the begins with option. That will find the matches immediately, and you could check them to see if they are caused by an extra space or something like that.