Clairvoyance inconsistant

So I’ve got Clairvoyance turned on in the PayTo category in a check book database with about 25,000 records. Sometimes it works and sometimes it doesn’t.

At times I have entered in a payee, and Panorama has binged and filled in the data. Then I’ll hit return to add another record, enter the exact same payee and nothing comes up.

There doesn’t seem to be much pattern to when it works and when it doesn’t except that it only works about half the time I try it.

It’s an old database, imported from Panorama 6, and there are definitely payees with typos, which of course will trip up the clairvoyance. But I’ve gone through and corrected the most common ones and it still only works about half the time on them.

Anything I’m missing here?


It’s obviously pretty hard to disprove a negative, but knowing how the code works it seems very unlikely that it would actually be inconsistent. If you look closely enough at the data, I think you’ll see that it is really doing the right thing.

Remember, just because you just entered something doesn’t mean it will come up when you enter it again – it depends on what else is in the database. For example, suppose your database contains the name Lynne. Then later, you enter Lynn. If you enter Lynn again, clairvoyance won’t come up, because it doesn’t know if you meant Lynne or Lynn. Clairvoyance only kicks in when there is an absolutely unique entry.

I’m sure you’re right that the code is not being inconsistent. It’s much more likely that the inconsistency is in my 10 year old, 25,000 record database.

However, there is a something weird going on and it’s not just different spellings thwarting the clairvoyance. I played with it more yesterday and found that when I ran across an instance where I thought the clairvoyance should be working but wasn’t (for example on a data entry where it had worked a few entries earlier), I could sometimes hand-type the entry, go on to another entry, then come back to the problematic one, delete the hand-entered data to retry it and the clairvoyance would work the second time.

Now, it’s quite possible this is due to some residual weirdness in the database itself. Maybe invisible characters in a field or extra spaces? Though I’d have no idea how they go there. Or some other minor corruption maybe.

It’s a minor annoyance, not a game stopper, so I can live with it for now. I can check to see if this is happening with other Panorama x files as well, old and new, or just this one, which would give a more definitive answer as to where the issue is, of course.


When that happens to me i run formulaFill strip(«») on all the text fields. This gets rid of leading and trailing spaces… Stripchar( is a good one to look at too.

Going to the data sheet and doing a Group Up on various fields is a good way to find near duplicates, too.


I have the same problem. Clairvoyance most of the time works fine, but regularly it doesn’t. As said before, deleting an entry and retyping brings CV back.

I think in all these cases the problem is that Panorama knows the data better than you do. You may not realize that there is a data item buried 10 pages up that prevents a Clairvoyance match on a certain prefix, but Panorama does. If you look at the data close enough, you’ll find the reason that a particular prefix doesn’t trigger Clairvoyance. So from your point of view Clairvoyance “appears” to be inconsistent, but it actually is perfectly consistent based on the entirety of the data in the database.

The buried data variation way back in the database may be what’s happening in many cases.

However, it doesn’t seem to explain what Huubg (I think) and I are experiencing: when entering one piece of data in a certain field, it doesn’t trigger CV, but if we delete just that one piece of data (not even the whole record) that we just entered, and re-enter it, CV recognizes it and triggers. The only thing seeming to change between the two cases is that one cell of data is deleted and re-entered identically. No other data in the same field has been changed so it’s not correcting some hidden past error.

It’s definitely a bit baffling.


Can it have something to do with using the tab key? When I click a field, CV always works.

Hmm, the tab idea is interesting. I’ll have to experiment and see if there’s a difference between tabbing and clicking. Thanks.