Can't log on to Pan X

One user has an m2 airbook running macOS 13.3.1

She’s been trying to use Panorama X ever since she got her new M2 airbook a few months ago, but has never been able to get logged in to our account. She has tried at home, and at our office, where both the office computer and my M2 airbook are logged into the panorama account.

When we launch Panorama X and open the site license window, it is already logged on, but the Role: pop-up menu is blank. After clicking the Log Off button, the spinner in the lower left corner spins for a while and then just stops. Nothing else happens. Panorama remains logged on.

I trashed the Panorama app and the Panorama X folders in Library-Application Support.

Downloaded pan x and unzipped it.

Launched it - same, logged on, clicked Log Off, contacting server, then nothing.

This user migrated from her previous Intel MacBook to the new M2 airbook before ever trying to use Panorama X. The firewall is off.

Have you been to the location to see the physical setup? By “physical”, I mean what apps are on the computer, what updates have, or haven’t been done, the files and perhaps second or third versions of the same app.

My experience is, sometimes, just over the phone, the user isn’t as comprehensive, or correct when describing the environment. The fact that many, many, many of us have installed PanX on M2 Macs, Intel Macs, and various OS’s indicates the issue is not within Panorama itself, but Panorama in conjunction with something about her computer. For example, is she using a VPN? I’m not saying that’s the problem; I use one all the time. However, occasionally it does get in the way of something I’m trying to do.

When you say, “contacting the server” - are you referring to the tie back to ProVUE’s login server or the PanX server setup when not in Single User Mode?

Maybe the preferences got corrupted during the migration. There is no way to uncorrupt them, but they can be deleted using these steps.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

I figured that got rid of any corrupted .plist. But if not, starting complete fresh is the way to go.

Then open/create a simple NEW file first, instead of trying to open something made earlier.

OK our nonprofit had a board meeting, so I was able to check out the office manager’s computer again. Quit panorama, trashed the preferences, rebooted the computer, and launched panorama X. This time the normal license screen came up and it wasn’t logged in. However, putting in our credentials for the user didn’t work. Again the spinner in the lower left corner spun, it said “connecting to server” for 20 seconds or so. Then the spinner and the message disappeared. There was no error message of any kind. I went through this procedure a couple of times but could never get connected to the ProVUE server to log in.

In the office there is a second MacBook Air M2, our office computer, and it’s been logged into panorama and using it for several months.

Any software installed on that Mac blocking outgoing internet connections e.g. LittleSnitch?

None that I know of. Little snitch is not installed, and if there’s some way to check for any blockages please let me know. The firewall is off.

You can click on the lock icon in the Site License window. If everything it is working it will display the server certificate information, as shown below.

If it’s not working it will display an error message with information about the problem.

Back on her Mac (she has tried logging in at home, and at the office, using those two different ISPs, with no success). I clicked the lock, and got the usual certificate window, looks fine. Trashed the prefs, rebooted, launched Pan X, clicked the lock again, certificate OK, then UNCHECKED the “Use secure connection…” checkbox. Then I entered our Email address and Password, with the PW shown, and tried to Log On.

No change, it spun and said “contacting server” for about 15 seconds, then that message and the spinner disappeared.

Pan 10.2.0.b33 (4268) on M2 AirBook with macOS 13.3.1 Ventura

After rebooting and launching, an error showed up, see image below, and my final attempt following the images:

I then installed the latest Pan X [ 10.2.0.b34 (4398) ], trashed the prefs again, and rebooted in SAFE MODE. Checked the certificate, looked fine, logged in again, no change. After the spinner and message disappeared, the Log In window was still there, with the Email and PW showing in the fields. No error messages showed up this time.

We currently have four other Mac notebooks connected to our Pan account, some M2s and some Intel.

The only thing I can think of that you haven’t tried would be to set up another user account on the computer (not a Panorama account, but a new user account), and see if that fixes the problem.