Best web server for database exchange?

I have lots of stuff to put up on the Database Exchange system but I need advice on a suitable (and preferably free) web server. Amazon S3 has been recommended as one option but, when I go looking on the web site, the proliferation of options is mind-boggling and their descriptions are not always clear.

Can anybody give me a clear path to accessing a good free web server?

Whilst waiting for advice on this topic, I’ve had a play with Amazon S3 and succeeded in uploading a zipped folder containing a Panorama X database and two versions of its documentation (in MS Word and PDF).

This is what’s in the folder:

When I enter the URL into the Database Exchange upload form and click Validate, the form activates a progress bar (presumably opening the zip file) and then displays the message, “Zip file does not contain a valid upload format.”

Any advice on what this means and how I fix it?

I think you need to upload a zipped database, and nothing else.

If my reading of the docs are correct you need to enter the public url for the folder first. Something along the lines of:

You would then need to change the Name entry to the name of your main Panorama X file without using the .pandb extension:

“Number Cruncher”

Now press the Validate button. I have not yet uploaded a folder with multiple files in it so I can’t actually verify this is all correct.

I believe that I did that - otherwise the Panorama X Exchange wouldnt have been able to unzip it. Here’s what I have in S3:

I copied the link into the Exchange box.

The documentation says to change the Name entry to the name of the Panorama X file but that name is the same as the folder. In any case, this is what I have:

Maybe it’s still a work in progress. I’ll try it again with just a database, no folder.

Let’s go over the basic just to be sure we are on the same page. The folder containing all your files is what should be zipped. In you case that folder seems to be named Number Cruncher. Once zipped it will be Number The public url for this would then be:

The Name would be: Number Cruncher.

So the zip file would be the folder containing all the files which are zipped when the folder is compressed. I would guess that the the Database Exchange will go in and unzip the folder and look for the Number Cruncher.pandb file and by not having included the .pandb extension to the file name you are indicating that a folder is involved. All supposition on my part - not having tried it all.

Note that the space in the url of the folder name is indicated by %20 and not the + sign you show.

We are certainly on the same page - I did all of the above, exactly as described (and as described in the Help wizard).

I wonder if there’s a bug triggered by the fact that the folder and file names are identical? I’ll check that out but from now until Sunday evening I’m a tad obsessed with motorsport on TV.

This puzzled me too but DB Exchange opens the zip file so it’s clearly not an issue.

Where are you seeing this in the Help wizard? I don’t see any reference to folders at all.

O.K. I see it now, when I got to the part about editing, I stopped reading.

Fatal mistake Dave - Jim always saves the best until last :slight_smile:

Maybe there is - I changed the name of the folder and now I can validate that the zip file is accessible and contains a Panorama database file. BUT, the Upload button is greyed out.

I get the same problem after validating a single database. I don’t know whether the problem lies with Amazon S3 or Panorama X but it looks more like the latter than not.

Returning to my original question, can anybody recommend another web server?

And, has anybody yet succeeded in uploading to the Exchange?

As you can tell from the files I have had included on the exchange, yes, I have been able to get things uploaded. The problem with the disabled Upload button is one I ran into as well. When I originally started working on the exchange with Jim I had this problem and he tried various remedies to fix it to no avail. I found that when I tried using the Close button on the window and then reopening and reentering and re-validating once or twice then at some point the Upload button would get enabled and I could then upload the file. I have since made it a habit to copy all my file info to a TextEdit window so I could simply copy and paste it back into a new attempt. I did not mention this to you previously because I wasn’t sure if it was simply a problem at my end since Jim could not resolve it at his end.

So, just keep trying and at some point it will go through. When it does, Jim will have to evaluate it and then have it entered in the Database Exchange. I see James Cook has a file entered as well and I’m guessing he has experienced similar problems uploading.

I guess I can try that approach - it will be a a pain because I have so many files to upload.

I’m surprised that Jim has left the Exchange active with this sort of undocumented problem.

Michael, this has nothing to do with the files you have already uploaded to the server. This only means you have to re-enter the info on a new Database Exchange Add Database drop down dialog sheet. For what it might be worth, I think after closing the sheet once and then going to another window and then back again that when I tried the next time and hit Close the sheet closed but then immediately re-opend with the Upload button enabled.

I understand that - it was the multiple repetitions of info entry hat I wasn’t looking forward to but, hopefully, your theory on the window re-opening is correct. Otherwise, Ill go back to Dropbox.

Question for Jim: Is a solution to this on the horizon? If not, I can appreciate that it has a low priority.

I’ve tried this more than a dozen times without success. I get validation but not an active Upload button.

When you say “another window”, is that in Panorama X or the Finder or another app? Would it help to sacrifice a chicken?

And BTW, I’ve demonstrated quite conclusively (al least to myself) that, if the folder name is the same as the database name, it will not validate.

James, do you have any suggestions?

Actually I had a lot of trouble getting the Upload button to activate. I tried the process over and over, every which way with several failures. Then with the Exchange window all filled in, I went to my account and looked over the settings. I figured logging out then in might be worth a shot. I logged out then clicked Close in the Exchange window. The Exchange window closed then re-opened with the Upload button enabled and I was able to upload my file.

Subsequent tries, out of curiosity, have all had the Upload button dimmed.

My file was apparently received without attribution since I as logged out. Jim Rea had to connect it to me.

Michael, for what it might be worth I just uploaded a folder to the Exchange containing my Wild Emojis file along with another folder holding the sound files that are used with Wild Emojis. Once I got verification that the folder was validated and I still had the Upload button disabled, I immediately started to navigate to other open windows including a couple of Panorama windows as well as other application windows. When I came back to the Database Exchange upload sheet and clicked the Close button the sheet closed and then immediately reopened with the Upload button enabled.

Whether this action caused the upload to work or If I just got extremely lucky I can’t say. I just wanted to verify that a folder with multiple files can actually be uploaded. Maybe your difficulty with all this is due to the Coriolis effect since you are in the southern hemisphere and your electrons are spinning in the opposite direction. Oh, yes, no chickens were harmed in my upload.

That seems to be the trick; activate other windows, then close the Database Exchange with the hope it’ll re-open with the Upload button activated.

That works James! I had one failure and then the second try behaved exactly as you described.

I do hope Jim can work out what’s happening here.