Backdrop doesn't show in printtopdf

First let me say WOW!! and thank you Jim!! for version 10.1(2790), especially expandable text. I have a form with the following tiles: Header, Data, Footer, and BackDrop. If I go to view menu and select my form, then File:Print, everything prints as expected to paper. I can even do File:Print, click the PDF menu and select Print To PDF / desktop - the form prints to pdf fine, including the backdrop.

However, I have a procedure that uses printtopdf - but the backdrop tile does NOT print. Here’s my procedure:

alert “Yes, No”, “Note: Field 1 on the TSL form (Page xx of xx) will not match the certified RRS, click yes to continue.”
If info(“DialogTrigger”) contains “No” stop endif
If info(“DialogTrigger”) contains “Yes”
Select «RMAN» = theanalysisrecords
Field “Status Official”
SelectWithin «Status Official» contains “x”
Field “New Org Name”
OpenForm “Form TSLDept”
printtopdf dbsubfolder(" PDFs RetentionSchedule")+"/Form TSLDept.pdf", “orientation”,“landscape”
openanything dbsubfolder(" PDFs RetentionSchedule")+"/Form TSLDept.pdf"

Thanks, Dusty

That is very strange – the exact same code is used to do the layout either way. It’s not similar code, it is the same code.

Have you tried using the Overlay tile? If the files on top of the BackDrop are opaque, you won’t see it. Though in that case, I would expect that you woudn’t see it when you print, either.

Yes, I tried the Overlay tile yesterday - same results when I use printtopdf - no BackDrop. It is strange because it works fine with file:print:popup menu print to pdf

Having a choice whether to print a backdrop tile or not would be a worthwhile addition, for printing things like 1099 MISC forms that have to be on IRS paper.

Another printing quirk for me in 10.1 - I’m finding that an image display object still displays on top of all other layers in any multiple object stack on a tile.

It prints OK as far as I can tell - the image display object doesn’t block anything anymore when printed - only when viewing the stack in a form, on the screen, regardless of changes to the stack order - i.e. “bring to front”, etc.

An example could be printing a pdf with PanX adding a time stamp in a corner, or adding a caption over an image. It seems to print the layers in the correct order, but when selecting an object and using “bring to front”, if I drag that front object over the image display object - it will be covered up with the image contained in the image display object.

Interesting though… if the image display object container is larger than the image, the other “front” object remains visible when still inside the image display object’s border.

When Viewing on screen, it looks like this: (I’ve put it in graphics mode to show the image display object boundary being larger than the actual image being displayed.)

When printed - it looks like this:

This doesn’t seem like it would be the intended outcome when viewing the form onscreen.

Finally - can a text display object have one color for the text and any color other than clear for the background in the text display object? I’m having trouble creating a text display object with any opaque color… the text ends up the same color as I might select for the “fill”.

The only way to do this other than having an additional colored object behind the TDO is have the Rich Text option checked for the TDO in the Properties panel along with the Mode set to Formula and include a background tag in the text formula as shown below.


I cannot duplicate your results. I get the exact same output from backdrop and overlay tiles whether I print using the print dialog or using the printtopdf statement. I am stumped as to why you are seeing different results in these two situations.

That is not what I am seeing. Here is an example, as you can see the image (the icon) is in front when it should be, and behind when it should be.


I am having a hard time following exactly what is going on in your example from just the screen shot. I guess the yellow box with the black border is the image? And the number 4 is a text object?

That is exactly as expected. Anything outside the image is transparent. And parts of the image itself can be transparent, or translucent, as is the case with the Panorama icon shown in my video.

Programming note: If possible, I would prefer if when a new subject is introduced like this, it would be placed in a new forum topic, rather than tacked onto an existing topic. That will make the forum easier to follow, rather than mixing multiple topics in a single thread.

I can get the layering to work as you show ONLY if I have the image display alignment option “Scale to Fit” or “Tile” selected.

When either alignment options “Scale to Fit” or “Tile” are selected - the layering appears to work as expected. I am able to move the text to the back and/or move the image display object or the text object to the front/back, etc.

If I set the Image Display “Align” option to “Top Center” or any other option except “Scale to Fit” or “Tile” - the layering no longer works and the image display object goes to the front of the stack - the text object is hidden, and the bring to front command doesn’t bring the text object to the front, nor push the image display object to the back.

I created two fresh PanX files and recreated this behavior both times - using both jpeg and pdf images displayed in the ID object.

If I set the image display object to “Scale to fit”, drag a text object into the middle of the image display object - the text object remains visible. If I then select the image display object and change it’s Align setting to “Center” (or anything but “Scale to Fit” or “Tile”), the text object disappears. Happens every time…

I’m hoping someone can re-create this…

What screen capture app are you using? I could try and make a video to demonstrate…

(apologies… I should have started a new topic.)

Sorry Jim, after comparing the two screen shots I SAW MY mistake. The procedure printtopdf was opening the form “Form TSLDept” when it should have been opening the form “Form TSL”. Sending the procedure to the correct form prints the BackDrop where I made changes to the Form.

I can duplicate this action. In my experiment only the Scale to Fit and Tile modes allowed the Text Display Object to overwrite the Image Display Object. Here is a video showing this action:


The image is of my dear old friend and companion Barnaby who has been gone for a few years now. Great guy and probably the purest soul I have ever known. Oh, I also tested this with a Rectangle Object and found the same results as with the TDO.

I cannot duplicate this problem. I get correct layering no mater what alignment option I pick.

Screenflow. Definitely overkill just for making a single video, but I use it for all of the Panorama X videos.

I’m running the latest Pan X 10.1 version on my iMac using system 10.13.4.

I’m running Pan X 10.1 on Macbook Pro using 10.13.6 and iMac Pro also on 10.13.6.

I’ll try and make a video - it will look basically the same as Gary’s…

Should I try anything? Delete preferences? Reinstall the application?

That is exactly what I am seeing here, too.
(Pan X build 2790, macOS X 10.13.6)

This is a spinoff of my original question. How can I name the pdf in the procedure below with the contents of the variable “theanalysisrecords”? Instead of naming it “Form TSLDept.pd”

Select «RMAN» = theanalysisrecords
Field “Status Official”
SelectWithin «Status Official» contains “x”
OpenForm “Form TSL”
printtopdf dbsubfolder(" PDFs RetentionSchedule")+"/Form TSLDept.pdf", “orientation”,“landscape”
openanything dbsubfolder(" PDFs RetentionSchedule")+"/Form TSLDept.pdf"

It’s just like any other formula, so like this:

printtopdf dbsubfolder(" PDFs RetentionSchedule")+"/"+ theanalysisrecords, “orientation”,“landscape”

My main development computer is running 10.12 Sierra. When I tried it on a computer I have with 10.13.4, I was able to see the exact same problem with the object layering. So the problem is operating system specific. I think I have an idea of how to fix it, I will try it tomorrow. Thanks to everyone for reporting their macOS version, usually it doesn’t matter but this appears to be one case where that turned out to be a key fact.

Thank you Jim, I see where I made my syntax mistake. I appended +".pdf" to my variable. Thanks again!

I have created a new version of Panorama X with one change – image layering works properly on recent macOS 10.13 systems. I tested it here and it seems to work, hopefully it will for all of you as well.

For the moment, I am not going to publish this as an “official” release, but if anyone wants to manually download it and try it out, it is available from this link:

1 Like