Add Mark not working

Choose Add Mark from the Mark menu. As expected, this appears:
But an instant later it changes to:

If you try to type the thing from the keyboard, as soon as you type --, it turns into .
In no case does it work as a mark.

If you type --anywhere in a procedure it is immediately turned into .

I’ve restarted PX and experimented with different procedures, but the behaviour persists. I tried opening a new database and it persists.

It seems like there’s a global replace( function or a global hot key rewriting the procedure text. Is that possible? (I’ve only defined window hotkeys, none using dashes.)

David Duncan

There must be more to this story. I’ve been using Add Mark constantly over the past couple of weeks, and it has worked flawlessly.

Also, I just tried typing -- and was able to do so with no problem.

I wonder – do you have some sort of keyboard shortcut program running, like TextExpander? If you had some program that was turning -- into you’d get exactly the symptoms you describe. And this sounds like something someone might want to do, turning two dashes into one em dash. Another possibility, check the shortcuts in System Preferences>Keyboard>Text.

AHA! I was able to duplicate your results by turning on Edit>Substitutions>Smart Dashes. It looks like this is a per-application preference, so you need to go to Panorama and then turn this option off.

If possible (and I’m not sure it is) it would be good if this option could be permanently disabled in procedure windows. I’ve added a bug report for this.

1 Like

That was a sneaky little feller.