A Simple Balance Checkbook Procedure No Longer Works

Sadly, I’m not a heavy duty programmer like so many of you are. I use Panorama for dealing with things in my small business and have for years. Upgraded to X because I want to upgrade my Mac to Sierra with minimal issues and Panorama is one of my most important programs.

I am lost in that I can’t even get a simple checkbook equation to work anymore in X.

This is what I used as my procedure to get my balance:

Field "Date"
Field "Date"
Column "Balance"
Equation Credit-Debit

Won’t run. :frowning:

I get an error that says:

CALL statement failed, procedure Balance Checkbook contains a compile error: Unknown statement: Column

Any clues what I am to do with this?

These are a couple of old legacy commands that are no longer recognized even though they still worked in Panorama 6. The Column command was listed in Panorama before Panorama II but not afterwards. I can’t find mention of the Equation command at all and might have been generated via the old recorder. Regardless, these can be easily made to run.

Field Balance 

Wouldn’t that affect the actual record only?

If you want to run the equation on all records of the field Balance, I would use
Field Balance
Formulafill Credit-Debit

You are correct. I just tried the Equation command in Panorama 6 and it was the same as FormulaFill.

Excellent. That seemed to work. Thanks!

Like I said, I have been using this a long time and when I originally setup these things up it was probably a decade ago, so I am sure I have “legacy” stuff in my databases.

Now, if I can ask a really stupid question…and it’s probably something obvious that I am missing, how come my keyboard commands no longer work. Delete no longer deletes a line. Command “a” no longer selects all. Heck, I can’t even add a new record by hitting the enter key. What the heck am I missing?

The delete key does delete a line for me. The enter key doesn’t give me a new record in either Panorama 6 or Panorama X. The return key gives me a new record in both. Command-A is disabled unless a cell is open, and then it selects all the text in the cell. This may be a bug. The Find/Select dialog doesn’t seem to have a select all option, so the only way I see to do it is with a method that is more advanced than it should be.

Under the Search menu, in the Find/Select dialog, choose Formula is true, and then enter this formula


That formula will be true for every record, and every record will be selected.

Sorry, Dave. I meant the return key. It says enter on the keyboard I am using, but that is the one. In Pan 6 I always hit enter (or return on some keyboards), let’s say in my checkbook ledger, to add a new row/record to my database.

Nope none of the keyboard commands work. Can’t select all, can’t enter a new record with return, can’t total columns, can’t tab from field to field. All of these actions I do in a normal day, when working within my databases. Also Panorama X is EXTREMELY slow.

I have restarted the computer and switched keyboards. Still having the same issues. We aren’t talking about a big database either. I think it’s less than 2000 records. I have some that are 42K+.

Strange, even though the Select All item is disabled, when I hit command-A the Search menu flashes and all records are selected.

I think the problem is I can’t even select a cell!!!

Command-A works as expected when you have selected a subset of your records before.

Yep. That works for me too. I saw the menu item was disabled, and assumed the keyboard equivalent would be as well.

Yes. I see that now as well.

Let me back up a bit and say that I am working within a form I created. When I go to the data sheet I can select and edit a cell, tab from one to the other, etc. I should have clarified that I don’t generally work in the data sheet, but rather a customer presentation of my data via a form I created.

Without knowing the design of the form, it’s hard to know just what is going on. It could be a bug, or a feature that hasn’t been implemented yet.

Understood. And, I know it is still in development, I am just a bit dissappointed that it is one hot mess for me. Thinking I may have jumped the gun a bit too soon for my skill level on this one. :frowning:

I think it is a good idea to go in the Graphic Mode of your form and to explore the many options shown in the properties panel. Maybe some of your cells are not set to be editable.

Neither the column or equation statements are listed in the Panorama 6 documentation, so that’s why I didn’t implement them in Panorama 6. I think they must have been from Panorama 1 or 2. However, I will go ahead and add them back in, I’ve made a bug report for this issue.

Very strange – you are correct, in a form, the Total command does not work if you are on the last record. It does work if you are on any other record. I’ve filed another bug report for this. Note that this has nothing to do with keys – it won’t work if you select it from the Field>Analyze menu.

Can’t select all

I sure can’t duplicate this. I have no problem using Command-A in either the data sheet or a form.

can’t tab from field to field

I also have no problem with the tab key in either the data sheet or a form.

can’t enter a new record with return

This is true, and intentional. I think the way that Panorama 6 allowed this in a form window was very “non-Mac standard”, so I left this out. I will consider adding it back as a preference. In the meantime, you can add it back into your database by adding a one line procedure to your database. Probably what you would want to do is create an .Initialize database so that this will run automatically when your databases opens. From then on, pressing the return key will add a new record (in that database).

definehotkeys "database","RETURN",{addrecord}

I think the slowness that you are experiencing may be due to the complexity of your form rather than the number of records. That is what I have found.

My forms are significantly complex and the speed of Pano X is unfortunately so slow that I can not use it. Movement from record to record has increased 700%. What takes me 3 seconds in Pano 6 now takes 20 seconds. Until this is resolved, I can not use Pano X.

Robert Ameeti
(949) 422-6866

I can duplicate all of this, if the form is a view as list. I think that’s probably the case here. In which case, a separate single record form will need to be made for data entry.

Yes, all of this makes much more sense if we are talking about a View-As-List form, I’m sure that’s it. Panorama X does not support data editing in a View-As-List form, that’s why you cannot select a cell or tab from cell to cell. This is not going to be a supported feature in Panorama X, so as Dave said, you will have to create a separate regular form for data entry.

I also confirmed that Select All doesn’t work in View-As-List forms, at least not from the menu (which is why Command-A doesn’t work). You can perform this function by clicking on the record count in the tool bar and choosing Select All from the pop-up menu.

I have filed a bug report on this issue.

Yep. That is exactly it. It is a view as list form. Good to know I’m not crazy then. LOL.