A Hidden NoShow?

As I continue to convert my Pan6 files to PanX, I keep running into weird problems.

The most recent one is when I “STOPPED” a procedure to help debugging (since debug still does not work properly), and the datasheet was empty. Even though I had just completed an importtext command which imported 24 records. The visible/total window showed the correct values, but no data.

But the data WAS THERE. When I clicked on a cell, the value of that cell appeared. But no other. If I were to click on each cell, I’m sure all records would be on-screen.

I added a ShowPage just before the STOP, and tried again. This time, everything was correct. All records were on-screen. I do not have a NoShow command in that procedure. Actually, I did have, but it is commented out. Entering a NoShow command earlier in the procedure does not correct anything. It has to be just before the STOP.

I seem to be an outlier. I’m having strange problems that others don’t seem to be experiencing. Is it possible, Jim, that when that corrupted file I sent you got corrupted, it messed up the underlying PanX application? How do I reload a brand new version of the program?

I confess I’m getting pretty frustrated.


To reload the program itself, just throw the existing app in the trash, then download a fresh copy from the ProVUE web site.

To completely clear out Panorama X, you would also need to clear out the preferences and application support folder. I gave instructions for clearing the preferences a couple of days ago, here they are again. I have also added additional instructions, shown in black, for deleting the application support folder belonging to Panorama X.

• If it is open, Quit from Panorama X
• Open a new window in the Finder
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Preferences/ and press the “Go” button
• Find the file “com.provue.PanoramaX.plist” and move it to the trash
• Choose “Go To Folder” from the “Go” menu
• Enter ~/Library/Application Support/ and press the “Go” button
• Find the PanoramaX folder and throw it into the trash
• Relauch Panorama X (this will automatically create new, default preferences)
• Log into your Panorama account

A couple of days ago I suggested creating a new user account and testing with that. Since each user account has a separate library folder, this would also have the effect of clearing out the preferences and application support folder, which was why I suggested trying that.

Hello Jim,

I did as you suggested above.

Now, when I invoke the procedure that was giving me the custom dictionary window error, I get a message window which states:


No error window, but no success. The second, and subsequent times I try, the macro works fine - just like before. Does the fact that the error window is suppressed, but instead a message window warning appears give you any clue?

Do you want to see the macro I run which results in the problem - not the database - just the macro? It’s pretty straightforward. But if so, I will send it to you through the private channel. I’ve taken up enough time from forum users.

By the way, just running the gettext command doesn’t cause any problems. I do that often in other databases.


You can send it, but I’m going to anticipate that it probably won’t be helpful by itself.

Are you using the customdialog statement anywhere?