10.2 server observations

I was the first person to install Butler, a beta tester of Enterprise and I’ve been testing Denali server for some time. I finally got some real world testing under my belt.

For the most part, the server is great. I had serious doubts in the early days about speed, however, I uploaded a complicated database with over 111K records, remotely, in 7 minutes. In Enterprise, this same database took around 6 hours to upload. BIG difference. Everything seems quite zippy!

I did encounter some issues. Several times after sharing a database, I immediately received a message that said “Can’t connect to server. Database is offline” . I don’t know how it got offline and I couldn’t figure out how to get it back online. I unchecked the share button and checked the “delete from server” button and hit “OK”. The file was unshared and I was able to reshare it with no issue.

Another database showed the message “Resume statement failed (no pause)” when I was tying to share the file. I couldn’t get out of the dialog and there was an Action menu with loads of procedures that I could access, but I couldn’t get out of the dialog. I had to force quit and reopen. I was able to unshare, delete and reshare as above.

While trying to share another I received the message “server variable ping load reply does not exist”. I was able to unsure, delete and reshare. I got the same message on another file, but when I tried to unshare it, I received another message that said “database does not exist (missing info.config)”. Tried again and received “Resume statement failed (no pause)”. This file is unusable at the moment. I can’t share or unshare it. I’m assuming if we look in the Public Databases folder, I should be able to delete whatever is in there and try again.

Lastly, one file appears to be shared, but there is no WiFi icon in the tool bar.

Otherwise, 18 databases were shared with few issues. I’m using 10.2.0.b24 on the client. The OS is 10.14.6. All files were shared by accessing the server remotely. Next, we do some parallel testing.

I think you are thinking that this message indicates that the server has taken the database offline. I don’t think that is what the message means.

After the database uploads, Panorama goes thru the same steps to establish the client-server connection that it always goes thru when opening a client database. If it can’t establish the connection, the local database is still in memory on the local computer, but it has no connection to the server so the data can’t be edited. This is what the “offline” message means. Perhaps the wording of this message should be changed to use a term different than “offline”, does anyone have suggestions.

Of course it is odd that it would be unable to connect when it just successfully uploaded the database to the same server. On the other hand a network connection can drop at any time.

In any case, my guess is that it wasn’t necessary to unshare and then re-share the database, probably all that was needed was to choose File>Connect to Server.

It is never necessary to force quit to get out of a Panorama dialog. Press the ESC key to cancel a dialog. In the unlikely event that doesn’t work, Press Fn-ESC, which essentially works like “force quit” for dialogs.

Is there any chance the message actually said serverPingReply does not exist?

Does the database show up in the Server Administration window? If so, you should be able to delete it from there.

I don’t think this file is shared. If there’s no WiFi icon, the connection process didn’t complete (assuming, of course, that the toolbar is visible). Why do you conclude that the file “appears to be shared”?

Sounds encouraging.

“Database is offline”

I tried File>Connect to Server in each case but I received an error that it couldn’t connect to the server because the database was offline.

“Couldn’t get out of the dialog”

I tiried the ESC key but I didn’t know about the Fn-Esc combo. What was up with the Action menu full of procedures?


I wrote down “servervariable ping load reply” after each occurrence. I guess I could have written it incorrectly twice.

“Unusable database”

The unusable database does NOT show up in the Server Administration window. I could have probably fixed the problem if it did.


I concluded it was shared because when I synchronized the file, it blinked and the record order was different. I didn’t actually see a progress bar but I thought that might be because there was nothing to synchronize. I unshared, deleted and reshared this file too. Each time it was in the same state. No WiFi icon but it seemed to be shared. I couldn’t test adding data to see if it updated two separate files yet.

I just checked again. The unusable database doesn’t show up in the Server Administration window, but it does show up in the Panorama X Preferences window in the client pane. The status is "Database does not exist (missing info, config).

At that point I would check the Server Admin window to see if the database really was offline on the server (I don’t know of any reason why it would be).

No idea.

The database options dialog does use an internal variable named serverPingReply.

Panorama itself doesn’t ever use server variables. So if the message really is “servervariable ping load reply”, I am at a complete loss.

I’m wondering if there even is a database on the server. You mentioned the idea of looking in the Public Databases folder, I’ll bet you won’t find anything there.

You should be able to “unshare” the client copy of the database no matter what is going on on the server. In fact, you can do this even if the server isn’t turned on or there is no connection to the server.

The last step of establishing the connection is to turn on the WiFi icon. If there is no WiFi icon, to me that means that something went wrong before the connection was established. I wouldn’t just shrug this off. If this happened to me (it never has) I would start turning on the various logging and instrumentation options to see what is going on under the hood. On the client side you can enable instrumentation for _EnterpriseClientLib and a ton of internal detail will be visible.

I’m not going to cover the details of using Debug Instrumentation because it is very well documented both in the help file and in the online classes from January, that was the first topic covered. All of the client and server code is very thoroughly instrumented so when there is any question about what is going on, the best policy is to turn on the instrumentation and it will generally tell you exactly. You can also look at the instrumentation logs for successful operations to see what it should look like.