Type letters with accents


#1

When typing letters with accents, I usually hold down the letter-key until a view pops up showing the available accents, then release the key and press the number for the accent that I want. This works in every program I have tried except Panorama Text Editor Object. In Panorama, this procedure results in two characters being inserted, the original unaccented character and the accented character. (This: eë instead of this: ë). Of course, there are better ways to insert the accents, if you remember the key combinations. Such as type option-u then the next character will get the umlaut (e.g. ü) and option-e for é.


#2

This was issue #396 in BitBucket. I reported the same thing you are here, after Jim marked it resolved.


#3

Ok, I re-opened the issue.

I never even knew this ability to pick with the number keys existed. That’s kind of cool, actually. It appears that Apple is somehow deleting the previous character, and whatever method it is using to do this is being blocked by Panorama’s code. So the original character isn’t being deleted, just the new one added.

But hey, at least the earlier fix stopped it from crashing!