Start up error alert

This alert shows up when I start up Panorama but is closely followed by an alert saying that the Beta is authorized. Everything seems to work after that.

Start Up Error Alert

Please open the formula wizard and run this formula:

info("unixusername")

I think it is going to show that your user name has a space in it. Unfortunately there is some code running there that doesn’t like that. I should be able to fix that.

I think I have a fix for you. Use View->Open View to open the procedure SETRUNNINGUNDERTERMINAL in _PanoramaLib. Then change line 5 of this procedure to:

let usertasks = lftocr(posixscript("ps -U "+unixshellstring(info("unixusername"))))

I believe the problem is that your unix user name has a space in it. This is extremely rare, but not unheard of (usually Apple makes this name for you without a space, for example mine is jimrea). I’ve encountered one other customer that had this – or maybe that was also you at some previous time. The correction above should fix it.

Investigating further I found the same problem in the code used to start up Apache, so there is another fix for that.

I made the change in SETRUNNINGUNDERTERMINAL, but it did not solve the problem. I’m pretty sure that this is because I do not know how to save the change. Upon restarting Panorama and opening SETRUNNINGUNDERTERMINAL, its text has reverted back. I tried saving a database after making the change and that didn’t work either. There’s a trick.
BTW info(“unixusername”) does show a user name with a space in it.

Save while the SETRUNNINGUNDERTERMINAL procedure window is still in front. That saves the library that contains that procedure.

Thanks Dave. That did end up saving the change.

Unfortunately Jim, that did not solve the issue.

Fortunately, it does not seem to keep Panorama 10.2 from running with only my programming errors crashing it.

I’m going to hope that you still have not actually saved the change. I can’t actually test it because I have no way to make a user with multiple names, but I don’t see how that change could fail to fix this problem. Once the next version is released, be sure to let me know if you still see this problem.

I am not so sanguine that there are no further repercussions from this. Maybe, but this error is interrupting Panorama’s initialization process, and any initialization code after this error will not run. So there may be additional problems due to this that you are not aware of yet.